Jump to content
Software FX Community

Refresh not Work


Recommended Posts

I'am using PowerGadget Creator. the version is 1.0.2588.21773. Windows XP - SP2

When execute this : 

get-date | out-gauge -refresh 0:0:1 -type digital -floating


get-wmiobject -class "win32_PerfFormattedData_PerfOS_Processor" | select Name,PercentProcessorTime | Where {$_.Name -eq "_Total"} | out-gauge -MainScale_Max 100 -flotting -refresh 0:0:1 -style 2

 Refresh not work ( the context menu not work)

excuse my english, but i'am french

Best regards




Link to comment
Share on other sites

I would recommend upgrading.  I've seen some issues with refresh in earlier releases.  I am currently running 1.0.2682.33396 (and can't remember if that's an interim build that fixes something minor).

This definitely works for me, so you should upgrade first, then retry:

get-date | out-gauge -refresh 0:0:1 -type digital -floating

Link to comment
Share on other sites

Zeppex: I don't know if PowerShell's execution policy will play a role in the gadget refresh mechanism. However, you may want to try changing the PowerShell execution policy to RemoteSigned and try to run your scriptagain. By default the PowerShell execution policy is set to Restricted.

To read your current execution policy you can type

PS> get-executionpolicy

and to set it you can type:

PS> set-executionpolicy RemoteSigned

I hope this helps.



Link to comment
Share on other sites

Just downloaded the Trial version (1.0.2588.21909), auto-refresh does not works. Using in XP.

We have only 60 days to try the PowerGadgets, can we have a version with auto-refresh ?


You're joining this thread late...  What exactly are you trying with refresh?

Have you tried something like this:

get-date | out-gauge -refresh 0:0:1 -type digital -floating

What if you tried this instead:

get-date | out-gauge -refresh 0:10:0 -type digital -floating

This time, you right-click on the gadgets and do a manual refresh...  What happens?

Link to comment
Share on other sites

I'm using 1.0.2588.21909 and the refresh works on my xp sp2 but not when using 1.0.2755.24126.

It seems the behavior is random as on zeppex machine 21909 doesn't work.


Or........Initially I had 21909 installed. Uninstalled and installed 2755.24126. Is there any setting or config file maybe left after uninstallation that affects the other builds?


Link to comment
Share on other sites

We have finally found and fixed the refresh issue.

In an interim build we tried to fix an issue with a localized PowerShell version and we introduced a bug that affects refreshing on scripts. You can download an updated build from the same place you downloaded it before (check that the file date should be July 23rd or later before downloading).


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...