Jump to content
Software FX Community

Gadgets don't work when I pipe output first.


eBuddha
 Share

Recommended Posts

Any time I pipe output into anything other than a powergadget cmdlt it just hangs.  For example this works fine:

 PS | out-chart

 Where this will fail:

 PS | where {$_.Company -like "*Microsoft*"} | out-chart

Powershell just sits there after executing the command, but never goes back to the prompt.  It works this way with every Powergadget any time I pipe output before sending it to a Powergadget.

I have uninstalled and reinstalled .NET, Powershell, and Powergadgets. Any ideas?

Link to comment
Share on other sites

There is a missing close quote in your pipe (after Microsoft*). First, I tried your line and got a >> symbol from PowerShell, which indicated that the line was not complete for execution. Then I realized about the missing quote and tried the following, which works fine for me:

PS | where {$_.Company -like "*Microsoft*"} | out-chart

I also tried your line without piping to out-chart, with the same results (>>): PS | where {$_.Company -like "*Microsoft*}

IvanG

Link to comment
Share on other sites

The email has been sent.  How was I able to download this "interim" version just the other night?  Shouldn't this be removed and replaced with the proper version?  That is a pretty major bug, and the version I downloaded was the only one available on your page.

Thanks for the help.

 

Regards,

 e-

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...