Jump to content
Software FX Community

3D Pie edge disappears with certain values


tfmillet
 Share

Recommended Posts

I like the 3D pie chart look that is in your sample AppDemo project (PiePage.xaml - DataTemplate Pie3).

 I have been playing with this style, and it works fine in some scenarios, and fails in others.

 Using this chart style, I'm doing the following in code:

List

<int> chartItems = new List<int>();chart1.Points.Clear();

chartItems.Add(35);

chartItems.Add(45);

chartItems.Add(20);

chart1.ItemsSource = chartItems;

The above code shows a nice 3D pie chart

 

If I change the code to look like this then I have a problem:

List<int> chartItems = new List<int>();

chart1.Points.Clear();

chartItems.Add(92);

chartItems.Add(2);

chartItems.Add(5);

chart1.ItemsSource = chartItems;

 

In this case, the top surface of the pie chart shows correctly, as does the shadow underneath.  However, the edge of the pie disappears.  It looks like a flat pancake, rather than the 3D look.

 I am new to ChartFX charts, so perhaps I'm not coding this right. 

Any insight would be appreciated.  I can send you the complete sample if it helps.

 Thanks,

Todd M 

 

Link to comment
Share on other sites

Some more info:

 I was referring to the Styling sample - in the solution it's Styling\PiePage.xaml.

 I've attached as screenshot of the two scenarios.

I also looked at just setting the View3D to Enabled on a standard chart.  However, the edges are jagged (no anti-aliasing?)

Is there a way to turn on anti-aliasing with a standard 3D pie chart?  If so, that would probably work for me.

 

Link to comment
Share on other sites

We have fixed this issue, if you want to receieve an updated build drop an email to wpf at softwarefx dot com.

>> I also looked at just setting the View3D to Enabled on a standard chart.  However, the edges are jagged (no anti-aliasing?)

I am afraid this is the default WPF 3D behavior in Windows XP (In Vista  WPF 3D content is anti-aliased). You can read this thread to get more info about why Microsoft decided to do this as well as a registry key to modify this behavior.

Regards,

JuanC

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...