Jump to content
Software FX Community

Access to the path 'C:\Program Files\Chart FX 7\ChartFX70\temp is denied

Greg in MD

Recommended Posts

I just installed Chart FX 70 on our production server, then moved a web app that's working on my development machine to the production box.  This is the error I'm getting:

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.UnauthorizedAccessException: Access to the path 'C:\Program Files\Chart FX 7\ChartFX70\temp\CFV0209_094123293DF.chs' is denied.

ASP.NET is not authorized to access the requested resource. Consider granting access rights to the resource to the ASP.NET request identity. ASP.NET has a base process identity (typically {MACHINE}\ASPNET on IIS 5 or Network Service on IIS 6) that is used if the application is not impersonating. If the application is impersonating via <identity impersonate="true"/>, the identity will be the anonymous user (typically IUSR_MACHINENAME) or the authenticated request user.

To grant ASP.NET access to a file, right-click the file in Explorer, choose "Properties" and select the Security tab. Click "Add" to add the appropriate user or group. Highlight the ASP.NET account, and check the boxes for the desired access.



I've installed ChartFX 70 sp 1, I've created the directory above and given IUSR and ASPNET full control to the directory.  I've made the directory a virtual directory through IIS.  I've done everything I can find on this site or google but can't get this working.  So I have a couple questions:


1) Is there a way to test that chart fx 70 is installed correctly on my production server?  When I installed it none of the samples were installed, which is to be expected on a prod server.  So how do I test that my install is working?


2) Is there some kind of property or config file for Chart FX that I can turn something on to get a more detailed error descritption?


3) This is the error I originally got, but I've tried so many things I forget what I did to change it to the error listed above.  However, it seems to refer to Chart FX 6 and the review date is 4/27/00 so I assume it's leftover code from something and may not be indicitive of what's really wrong.

CFX61B0-3 : Error creating temporary file.

Could not find a part of the path 'c:\inetpub\wwwroot\chartfx70\temp\CFV0209_12115317575.chs'.

the above error message was hyperlinked to this page:




Any input is greatly appreciated.  My head is really starting to hurt from pounding it against the wall.






Link to comment
Share on other sites

I hate being the first to reply to my own post but...

I just went into the Sharing & Security properties for the C:\Program Files\Chart FX 7\ChartFX70\temp folder and gave the Everyone group full control and now my charts are working.

 Obviously, I don't want the Everyone group to have Full Control.  Can someone tell me what user should have what rights to that directory so my charts will work?





Link to comment
Share on other sites

 Whenever I see the CFX61B0-3 error, the first thing I do is check to see that the ChartFX70 virtual folder was created in IIS and that it in fact points to to the correspondent ChartFX70 folder inside the installation folder. Also that the folder contains the Download and Temp sub-folders. I believe this is true in your scenario, just figured I posted it here if someone else is having the same issue.

Now, as far as permission goes, I belive all you gotta do is enable anonymous access to the virtual directory in IIS. So not Everyone needs Full Control, just IIS (and the impersonated user) needs access to read those files.


Im assuming you are not ussing any kind of authentication, am I correct?

Link to comment
Share on other sites

  • 1 year later...

Hello there, Looks like this problem have not been raising since last year :) But anyway.

Your reply is must be a joke, I really can't call it serious. Can you please answer couple questions?

1. WHY do I need to have virtual folder for ChartFX in my IIS?

2. WHY your Chart control must access that virtual folder and create temp files in there?

3. WHAT should I do to have ChartFX Web control working "out of the box" with ChartFX Silverlight control? Except doing some weird things on my IIS of course.

I'll be very gratefull to you for detailed answer.

Thank you.

Link to comment
Share on other sites

  • 2 weeks later...
  • 3 months later...

This problem (CFX61B0-3) usually happens when the temp folder is not automatically created in your site. Please make sure the temp folder exists on your site. Please note that the ChartFX70 folder must contain three folders: Download, PSS and Temp. Sometimes the temp folder is not there, so you just need to manually create it in the chartfx70 folder. The PSS virtual folder needs to be running as an application on IIS and able to execute scripts only. The entire ChartFX70 virtual folder needs to have read/write permissions.


Link to comment
Share on other sites

  • 1 year later...



I applied your suggestion but still no luck. i followed same steps but still there is broken image. Can u help me what is problem with it then. I also applied permissions and other stuff which is written in this forum but still no +ve results.


Please help me.





Link to comment
Share on other sites

  • 1 month later...

At one point we did get it working.  I think it had something to do with Write permissions to the temp directory or the ChartFX temp directory and the IUSR account for IIS, but I don't remember exactly what it was anymore.  That was on Windows Server 2003 and IIS 6.0.

We moved to Windows Server 2008 and IIS 7 last year and had even more trouble with ChartFX so we scrapped the whole thing and converted our charts to use the Microsoft charting control, which is free, and can be added to the VS 2008 toolbox or comes with VS 2010.

The only apps we use ChartFX for anymore are our Windows desktop apps.

Sorry I couldn't be of more help.

Good luck.

Link to comment
Share on other sites

Hello pkuehn,
First of all I would like to apologize for the trouble you are having with our products. It is my goal to make sure that this issue gets resolved.

I do not understand how you got to the conclusion that our software is a scam. Every developer that acquires Chart FX 7 does so by purchasing a Studio FX Premium Subscription. While we do require a valid subscription in order to obtain support, we deliberately include full support (via email and phone) with every yearly subscription. Having purchased a subscription yourself recently, you should be aware you have a valid support account until late 2012 (I will not post your account number here for obvious reasons, but let me know if you need a reminder email). You may at any time call 561-392-2023 or start a new incident at www.mysoftwarefx.com. I am actually curious to how you got to the conclusion you need to upgrade to obtain support.

I would also like to point out that Chart FX 7 is running successfully on thousands of machines. And while some minor adjustments may necessary to get the product to work on every environment (such as manually granting write permission to IIS USER on the ChartFX70 virtual folder), we have yet to run into a scenario where we could not make Chart FX work. If such environment does exist, we would be extremely interested in observing the case to make sure we can further improve our product and make it compatible.

All that I can tell from your post is that you are having issues with Chart FX because access to path C:\Program Files\Chart FX 7\ChartFX70\temp is denied. You did not mention whether you are getting a broken image or a CFX61B0-3 error. You mention you have tried everything on the post but since the error is very clear (access to path denied) I can

Link to comment
Share on other sites

I'm in the same situation as your. We just bought the ChartFX product as well. When we deployed to the test server, the charts didn't show up. Our testing is coming near and we couldn't make it work. Every time I tried to contact them, they told me to post the issue by using this link  www.mysoftwarefx.com. Hower when I clicked on this link they required me to buy subscription. I'm stuck.

We changed security as listed in the forum but no luck.


Link to comment
Share on other sites

Hello Young,

The fact that you are experiencing the same symptoms does not mean you have the same issue. Once again I urge members of this forum to stop posting to this thread and create a new thread reporting your issue instead. Different users have reported different symptoms on different environments under this thread and when a new user says he is experiencing the same thing it becomes a very ambiguous statement. If you would like help from the community, please create a new thread explain all your symptoms, all you have tried and a brief description of your environment.

On the subject of support I would like to make clear that it is in Software FX

Link to comment
Share on other sites

I called and they told me I did not have phone support.  Thats fine.  I understand but your KB did not have the answer and the only other option is to spend many more $$$ to get it to work when I am already under a time crunch.

I have been using chartFX for almost 10 years.  Believe me I really like your product.  I have not talked to support for such a long time but I did remember them being very accomodating in the past. I guess I am just dissapointed that Just spent so much $$$ on a control and I dont get any help installing on my production machine when obviously it is such a common problem. I didnt see the point in spending another pile of $$$ upgrading my support for a call I will make once. It would have been a 3 minute fix for someone that should not even be a problem in my opinion. 

Believe me searching your forum is the first thing that was done. When you search the issue this thread comes up.  Thats why this thread is being used even if it is 3 years old. 


 I STOPPED and RESTARTED the APPLICATION POOL assocated with the website and it started working. 


Link to comment
Share on other sites

Hello Pkuehn,

The information you got over the phone is incorrect and I apologize for that. You do qualify for phone support. Maybe you did not provide them with the correct Serial Number? The Serial Number that qualifies you for phone and web support starts with SFXPUD. If you need to be reminded of that Serial Number, please contact sales [at] softwarefx.com. Also, if you have any other questions (supported related or otherwise) please feel free to contact me directly by sending me an email (use the Contact button on the top of this post). If you ever need us for anything else I would like to make sure you are properly taken care of.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...