Jump to content
Software FX Community

Interactive display for chart

User (Legacy)

Recommended Posts

I have used ChartFX 5.5 in the past without too many complications.

However, since trialling Chart FX .Net I have been unable to display a

interactive chart using vs.net 2003.

So far, I am able to view the default chart as an image, no problems here.

When I change the htmltag to "Auto" it defaults to image as well. When I

set it to ".Net" nothing appears on screen. However, if I paste the code

from url

http://support.softwarefx.com/Article.aspx?KBID=6121017&Product=CfxJava&Embed=0 I

can view an interactive chart.

So, my question is how do I view an interactive chart by placing the control

on a web form and passing data to it oin the codebehind?

Other things I have tried is to change the permissions on the .Net framework

1.1 & 2.0

Check the permissions on the Chart FX download directory

Tried to view the chm file in notepad but it seemed to be a binary file.

Here is the object tag produced:

<object id="Chart1"


WIDTH="300px" HEIGHT="300px" >

<PARAM NAME="DataCookieId" VALUE="a3fco1j2yxrmjiuiqhtgad55">

<PARAM NAME="DataPath" VALUE="/chartfx62/temp/CFT0722_114534345EC.chw">

<PARAM NAME="AssemblyTarget" VALUE="ChartFX.Internet.Client,

Version=6.2.2343.17219, Culture=neutral, PublicKeyToken=a1878e2052c08dce" >

<PARAM NAME="ClassTarget" VALUE="SoftwareFX.ChartFX.Internet.Client.Chart" >


Any help appreciated.


Link to comment
Share on other sites

We need a little bit more info on this.

When you say: "When Iset it to ".Net" nothing appears on screen", what do

you mean by nothing an empty page ? a broken image icon ? An exception ?

Try the following:

1) Set chart.MainClient = false at design time, using the property grid.

2) Set HtmlTag to ".NET"

3) Run the page

If the chart doesn't show, do a view source and look for the object tag,

copy the value of the DataPath property and paste it in your browser's

address bar, preceded by your server name. for example if your page is:


and your DataPath value is "/chartfx62/temp/CFT0722_114534345EC.chw"

You will put:


in your address bar. What do you get ? If you get a Save As prompt, then

there is no problem with server-side permissions, the problem is most likely

in the client. Check the .NET security settings in the CLIENT for all

versions of the .NET framework installed.


Francisco Padron


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...