Jump to content
Software FX Community

Pie-Chart: Problem with Point-Labels


Doc Holliday
 Share

Recommended Posts

Hello,

In my Pie-Charts the PointLabels will be file:///C:/DOKUME%7E1/HKOELB%7E1.DAP/LOKALE%7E1/Temp/moz-screenshot.jpgtruncated. (see attachment)
I'm using the following code for initialization.

  ((ChartFX.WinForms.Galleries.Pie)m_Chart.GalleryAttributes).Square = true;
  ((ChartFX.WinForms.Galleries.Pie)m_Chart.GalleryAttributes).LabelsInside = false;
  ((ChartFX.WinForms.Galleries.Pie)m_Chart.GalleryAttributes).LabelLineBreak = 10;
  ((ChartFX.WinForms.Galleries.Pie)m_Chart.GalleryAttributes).Stacked = false;
  ((ChartFX.WinForms.Galleries.Pie)m_Chart.GalleryAttributes).MaximumLabelMargin = 100;

In other Posts in this Forum I get the information that I have to set  MaximumLabelMargin = 100.
But it doesn't work.

Is their any other possibility to force the Pie-Chart not to truncate the Labels ?


 

Link to comment
Share on other sites

  • 1 year later...
  • 2 weeks later...

This problem is fixed. Notice that labels can be clipped if the MaximumLabelMargin (Pie class) is set to less than 100.

If yo want to guarantee no labels will be clipped (as long as there is room to show them) set:

((ChartFX.WinForms.Galleies.Pie) chart.GalleryAttributes).MaximumLabelMargin = 100;

Notice that by doing this you are allowing the pie itself to become very tiny in favor of displaying the labels.

Link to comment
Share on other sites

Hi,

Unfortunately, there is no built-in feature to enable label-wrapping. However, as a workaround you can specify a line break (\n) when defining a value for the text property of the point class:

Chart1.AllSeries.PointLabels.Format =

"%L";Chart1.Points[0, 0].Text = "Line1 \n Line 2";

Regards,

RandyJ

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...