Jump to content
Software FX Community

permission of type 'System.Web.AspNetHostingPermission!!!!! Please Help


lb7226
 Share

Recommended Posts

I am currenlty using the chartsfx Internet version 6.2 in Visual Studio 2005.  After I follow this process :

1: Create a New Web Forms project in Visual Studio .NET

2: Select the Web Forms Tab.

3: Right-click on the Toolbox background.

4: Select Customize Toolbox.

5: On the Customize Toolbox Dialog, select the ".NET Framework Components" tab.

6: Press the "Browse" Button.

7: Locate and Select the "ChartFX.Internet.dll" assembly on the Chart FX bin directory.

I select build and recieve the following error:

 Request for the permission of type 'System.Web.AspNetHostingPermission, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' failed. 

Now it is probably important to add that I do not have this problem with Visual Studio 2003 or in Visual Studio 2005 if I have the app locally.  The problem only occurs with the site in Visual Studio on a remote server.

Link to comment
Share on other sites

The exception that you are receiving is not related to ChartFX but to the permission settings of the .NET Framework. If you try the same process with an application that does not have ChartFX, are you able to build it?

You more than likely will need to configure the Code Access Security Policy. You can refer to the following article about this topic:

http://www.15seconds.com/issue/040121.htm

Link to comment
Share on other sites

IF I remove the ChartFx the project will build.  It also works if I use Visual Studio 2003.  I have configured my Internet Zone to Full Trust, still, with no luck.

I also tried to create a new 2005 web project and included only the ChartFx.internet control into it.  This as well will not build.  Again I have no trouble following the exact same process with building in a 2003 project

Link to comment
Share on other sites

The error that you are receiving is a framework issue. Please note that ChartFX for .NET 6.2 uses Framework 1.1; however, Visual Studio 2005 installs Framework 2.0 though, so the client instead of using Framework 1.1 will use 2.0. If you configured the trust settings as you did above, make sure you are doing so for the .NET Framework 2.0 and make sure that My Computer and Trusted Sites are set to "Full Trust" as well as the zone where your application runs on (Internet or Intranet). You can follow these steps:

1. Open Control Panel->Administrative Tools->.NET Framework 2.0 Configuration

2. Click on "Configure Code Access Security Policy"

3. Click on "Adjust Zone Security"

4. Now click on next to make changes on your current computer

5. Finally set Intranet, Trusted Sites, My computer to Full Trust

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...