Jump to content
Software FX Community

class doesn't support Automation


kalyan_nani
 Share

Recommended Posts

 Hi,

I am using chartfx for visual studio 2005. 

I have recently updated my chartfx service pack.

From that moment onwards I am getting "class doesn't support Automation" error when I try to access the chart using Javascript.

Using JavaScript I am  just hiding/unhiding the series.

It was worked previously with out any issues.

Old version:7.0.2664.18534

New version:7.0.2893.24916

 can you please help me?

Link to comment
Share on other sites

I have yet to replicate this issue. I am attaching a sample project that toggles a series on/off using JavaScript. If this works for you, please see what is different in your application.

If you are still experiencing this problem, let me know the details of the issue (eg. Viewing page on client-side or from within Visual Studio, etc.) or provide me with a full-blown sample project that replicates this problem. The markup code alone will not allow me to replicate the issue.

Link to comment
Share on other sites

  • 2 weeks later...

I also get the error Microsoft JScript runtime error: Class doesn't support Automation when the line

chart.Series.Item(0).Visible = !chart.Series.Item(0).Visible; is executed. I am running the sample code you provided. I am running XP and IE7. Apparently you have some security setting or some other setting configured that we don't. Have you tried this on a machine with a clean installation with all of the XP and IE7 updates? I would like to know what you have configured so that we can resolve this issue.

 Thank you.

Link to comment
Share on other sites

Ok, thank you for the information. Please note that the sample I provided for you renders the chart as .NET; this means that if you are going to execute client-side code (JavaScript) using a .NET control, you may need to set the .NET Framework Trust Settings to "Full Trust".

Please confirm that you have the .NET Framework on the client-machine executing the page set to "Full Trust" for the zone where the application is being executed on.

Link to comment
Share on other sites

  • 5 months later...

 Hi, I have the same problem. But my project is going to be executed on thousands of the company intranet so, we can't tell to our customer that they should change the security settings neither run configuration commands due to they are limited users and probably they haven't permission to execute those kinds of commands. Has somebody manage to fix this problem?

 

Link to comment
Share on other sites

  • 5 weeks later...

 

I found a fix for this issue - it started with some update way back in 2002 and has continued to do the same for years...Here is what I found - and the link to the entire forum. There is about 50 people that replied saying this worked for them once they were re-registered....I just sent it onto a Client that is running Vista / IE7 Combination. So I am hoping it will also fix their issue as well. - Good luck!

http://www.annoyances.org/exec/forum/winxp/1059879016

>I fixed this issue by clicking on "Start Menu" - "Run", and entering the following

>entries on command prompt:

>

>regsvr32 msscript.ocx [enter]

>regsvr32 dispex.dll [enter]

>regsvr32 vbscript.dll [enter]

>

The cause is still unkown - However there is one writer that did a lot of testing and came back with the reason behind the errors:

Been dealing with this issue for months, thank you to the poster who let us know the proper .dlls to re-register. The dispex.dll was the one that worked for me. I tested this by unregistering and re-registering the dll several times. If you are missing it you can get it here: http://dll.yaroslavl.ru/index.php3?lng=&in_char=D I'm not sure how current it is though. The Cause: One of two things, either a bogus update from MS (http://windowsupdate.microsoft.com) that breaks the scripting mechanism by unregistering files and not registering them again. Or The Visual Studio .NET installation on IE6 SP1. That's what I've come up with after a little research. If you know of another means, please post! I am just happy to have things back in working order!!!!!! DeAdWhAcKeR

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...