Jump to content
Software FX Community

Installation problem under RHEL


mjstudio
 Share

Recommended Posts

I got an  "No X11 DISPLAY variable was set." exception when I ran the installer. Any help will be appreciated.

[root@localhost]# ./cfxjava65prod.binPreparing to install...Extracting the installation resources from the installer archive...Configuring the installer for this system's environment...Launching installer...Invocation of this Java Application has caused an InvocationTargetException. This application will now exit. (LAX)Stack Trace:java.awt.HeadlessException:No X11 DISPLAY variable was set, but this program performed an operation which requires it.   at java.awt.GraphicsEnvironment.checkHeadless(GraphicsEnvironment.java:159)   at java.awt.Window.<init>(Window.java:406)   at java.awt.Frame.<init>(Frame.java:402)   at java.awt.Frame.<init>(Frame.java:367)   at javax.swing.JFrame.<init>(JFrame.java:163)   at com.zerog.ia.installer.LifeCycleManager.g(DashoA8113)   at com.zerog.ia.installer.LifeCycleManager.h(DashoA8113)   at com.zerog.ia.installer.LifeCycleManager.a(DashoA8113)   at com.zerog.ia.installer.Main.main(DashoA8113)   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)   at java.lang.reflect.Method.invoke(Method.java:597)   at com.zerog.lax.LAX.launch(DashoA8113)   at com.zerog.lax.LAX.main(DashoA8113)This Application has Unexpectedly Quit: Invocation of this Java Application hascaused an InvocationTargetException. This application will now exit. (LAX) 

Thanks,

Link to comment
Share on other sites

Hi, the installer is graphical, it wouldn't work in console mode.  Annyway, you don't really have to run the installer on the production server, you can just copy the files from you developmet environment, and obtain a license for the production server using the activation servlet or by following any of the other procedures described in the docs.

Link to comment
Share on other sites

Thanks for the reply, that solved the installer problem. However, after I copied the files from my development environment to production server and activated license, the Flash charts could not be displayed, the png/jpeg charts are fine.  I have changed permission of folder /chartfx62/temp to 777, but it did not solve the problem.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...