Jump to content
Software FX Community

Chart not rendering


LSUgirl
 Share

Recommended Posts

Hi,

I've added a new 7.0 chart to a new aspx page in a project that has 6.x and 7.0 chart FX.  I'm able to edit the chart in the designer.  When I run the aspx page, the chart is loaded but not displayed.  I only get a red X.  If I hover over the chart, I get the correct tooltips (with the correct data).  I can right click and get the chart menu.  So seems that everything is working except displaying the chart.  Any ideas?

To "update" the project, I added all the ChartFX.WebForms.*.dll to the bin directory and changed the references.  I couldn't find any other documentation if something else needed to be done to get the project to work.  I'm able to run the sample 7.0 projects without issue.

Link to comment
Share on other sites

Looks like some sort of configuration problem.

Do a View Source in your page and locate the Chart FX <img> tag (the id will be that of your Chart control).

Where is the source pointing to? Is the url valid?

Are you running your app from IIS of from within Visual Studio's ASP.NET Web Server?

Link to comment
Share on other sites

My chart doesn't have a <img> tag. I created the chart by dragging the chart from the toolbox.  In the codebehind, I set

Chart1.Gallery =

Gallery.Pie;

My chart in my aspx page:

<chartfx7:Chart ID="Chart1" runat="server" Height="300px" Width="300px">

<Series>

<chartfx7:seriesattributes />

<chartfx7:seriesattributes />

<chartfx7:seriesattributes />

</Series>

</chartfx7:Chart>

 

Yes, I'm running in debug mode (iis with asp.net web server).  I'm using the PassingData sample as an example.

post-2932-13922400437706_thumb.jpg

Link to comment
Share on other sites

1) By do a View Source i meant in the browser.

2) My question about IIS is about the web server not whether or not you are running in debug. VS 2005 supports two kinds of Web Projects:

- In the file system: Uses internal ASP.NET Web Server. You can detect this easily by looking at the url in your browser (when you run) if it has a weird port number then you are running in this mode,

- Using IIS.

I need to know which one is your case.

Link to comment
Share on other sites

sorry.  I thought you meant in the designer.  In the view source,

<img id="Chart1" src="/chartfx70/pss/ChartFX.aspx?id=0-072015200&type=png&mime=image%2fpng"  WIDTH="375" HEIGHT="250"  usemap="#Chart1Map" border="0" oncontextmenu="return SFX_OnChartContextMenu();"/> 

I'm using IIS.  My url is something like http://localhost/WebApplication2/default.aspx

I've done some more testing and I do think it's a configuration setting but I don't know the issue.  I have created a test project and added a test aspx page with a hard-code data table to populate the chart.  That works!!  If I request the user log into our databse and call the same page (will the hard-code dt), the chart isn't rendering.  The page itself is not changing.  The only thing changing is the web.config to log in the user.  I will have to look closer into this because it is a requirement that our users log in. 

Link to comment
Share on other sites

when I compare the page trace side by side (no log in and with log in), the major different is the AUTH_TYPE.

 In the instance where they log in, the AUTH_TYPE is FORMS

<

authentication mode="Forms">

In the instance where they don't log in, the AUTH_TYPE is null even though the above line is still in the web.config.  Do you know of any issue the chart would have with the AUTH_TYPE?  I'm just grasping at straws.

Link to comment
Share on other sites

If you are using Forms Authentication, please check teh following KB article:

Q7621009. How to use Chart FX and Forms Authentication to secure your charts

URL: http://support.softwarefx.com/Article.aspx?KBID=7621009&Product=CfxNet70&Embed=0&_r=1

 I think the problem you are having is due to the issue discussed in this article. If so, the article has the information you need to fix it.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...