Jump to content
Software FX Community

Problem with VS2005 Professional SP1


slewis78
 Share

Recommended Posts

I've installed ChartFX Lite (ChartFXLiteNet.exe, 6.0.839.0) and added it to my VS2005 toolbox. All that worked fine.

I started a Windows Form application (so using Managed C++) and added a Chart component to the default Form1.  I immediately try to compile and get the following error:

Error 1334 error C3699: '^' : cannot use this indirection on type 'System::Drawing::Font' c:\a\test785\test785\Form1.h 60

With this line of code:

 this->chart1 = (gcnew SoftwareFX::ChartFX::Lite::Chart());

Does ChartFX Lite support Managed C++ and VS2005?  The documentation seems to suggest that it might not (it only mentioned VB and C#, and I believe the download says for VS2003, whereas the ChartFX 30-Day Trial says it's for VS2005).  

 

Suggestions?

 

Link to comment
Share on other sites

Below is the entire program. Indeed, Line 60 doesn't apparently have anything to do with the Font datatype. Line 60 itself is as follows:

this->chart1 = (gcnew SoftwareFX::ChartFX::Lite::Chart());

 And "chart1" (the default name of the chart as attached to the form) is declared as follows:

SoftwareFX::ChartFX::Lite::Chart^  chart1;

It is using the ^ type modifier. I don't have VS2003, and just want to know if ChartFX Lite works with VS2005 C++ so we can evaluate it before using the real versions.

__________________________________________________________________________ 

#pragma once

namespace test785 {

 using namespace System; using namespace System::ComponentModel; using namespace System::Collections; using namespace System::Windows::Forms; using namespace System::Data; using namespace System::Drawing;  using namespace SoftwareFX::ChartFX::Lite;

 /// <summary> /// Summary for Form1 /// /// WARNING: If you change the name of this class, you will need to change the ///   'Resource File Name' property for the managed resource compiler tool ///   associated with all .resx files this class depends on.  Otherwise, ///   the designers will not be able to interact properly with localized ///   resources associated with this form. /// </summary> public ref class Form1 : public System::Windows::Forms::Form { public: Form1(void) {  InitializeComponent();  //  //TODO: Add the constructor code here  // }

 protected: /// <summary> /// Clean up any resources being used. /// </summary> ~Form1() {  if (components)  { delete components;  } }  private: SoftwareFX::ChartFX::Lite::Chart^  chart1;  protected:

 private: /// <summary> /// Required designer variable. /// </summary> System::ComponentModel::Container ^components;

#pragma region Windows Form Designer generated code /// <summary> /// Required method for Designer support - do not modify /// the contents of this method with the code editor. /// </summary> void InitializeComponent(void) {   this->chart1 = (gcnew SoftwareFX::ChartFX::Lite::Chart());   this->SuspendLayout();   //   // chart1   //   this->chart1->Location = System::Drawing::Point(124, 72);   this->chart1->Name = L"chart1";   this->chart1->NSeries = 0;   this->chart1->NValues = 0;   this->chart1->Size = System::Drawing::Size(150, 150);   this->chart1->TabIndex = 0;   //   // Form1   //   this->AutoScaleDimensions = System::Drawing::SizeF(6, 13);   this->AutoScaleMode = System::Windows::Forms::AutoScaleMode::Font;   this->ClientSize = System::Drawing::Size(292, 266);   this->Controls->Add(this->chart1);   this->Name = L"Form1";   this->Text = L"Form1";   this->ResumeLayout(false);

  }#pragma endregion };}

 

 

Link to comment
Share on other sites

I believe we resolved the problem.

Our Windows Forms Solution file apparently had redudant references to assemblies in both .NET and GAC. I'm not sure where the GAC assembly references came from.  But we went to the project settings and removed the redundant ones. Now we no longer get the compiler error, and can at least compile the VS2005 Windows Form project with the ChartFX component added.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...