Jump to content
Software FX Community

http 401.5 error - Location of chartfx.webforms.config - ASP.NET 2.0 website


ranganh
 Share

Recommended Posts

Hi,

Referring to your documentation, I see that

ChartFX.WebForms.config has to be included in the bin folder of your web application

However, in a ASP.NET 2.0 website application, the code files are compiled on demand, hence there is no bin folder for a website application.

 Where should the chartfx.webforms.config file be placed in such a situation?

The reason I am trying to have chartfx.webforms.config, is -

When I access the URL http://myserver.com/chatfx70/pss/chartfx.aspx?...

the IIS log shows a HTTP 401 5 error.

I am assuming that the chartfx.aspx HTTP handler has returned an authorization failure, as my website app uses forms authentication, whereas the PSS app web.config does not.

So I would like to create a chartfx.webforms.config with an entry

<Authenticate>false</Authenticate>

Now the only problem is I am not sure where to place the chartfx.webforms.config file.

Thanks!

Hari

Link to comment
Share on other sites

There should be a Bin folder. That's where the Chart FX assemblies (and any other external assemblies) are.

What's compiled on demand is your ASPX files (and the code behind), eternal assemblies are not (there is no source code for them).

 The config file must be in the same place ChartFX.WebForms.dll is in your application.

 The following KB article explains how to implement FORM authentication using PSS.

http://support.softwarefx.com/Article.aspx?KBID=7621009&Product=CfxNet70&Embed=0

Notice that the article calls for modifying Web.config for both your app and PSS.

Link to comment
Share on other sites

I will check the bin folder and post later an update.

On the authentication piece, I do not want chartfx PSS handler/service to use any authentication, which is why I have

<Authenticate>false</Authenticate>

In spite of above setting, would chartfx PSS still authenticate requests for the chart image?

Link to comment
Share on other sites

You are right about the bin folder, I have moved the chartFX.WebForms.config with Authenticate = false to the bin folder.

As for the 401.5 error, I moved the http handler to my web application

1) including the http handler in my application web.config

2) Copying ChartFX.PSS.HttpHandler.dll to application bin folder

3) changing HandlerURL in chartFX.WebForms.config as

<HandlerURL>/MyVirtualDir</HandlerURL>

This appears to have fixed the 401.5 issue. The chart is coming up just fine.

Thanks to you for prompt response and pointing me to the right KB article.

Link to comment
Share on other sites

Good to know that you got it working.

One comment: By setting Authenticate to false you may be leaving a security flaw that will allow people to see the charts generated by others. Please refer to the above mention article if you want your charts to be secured using Form Authentication,

post-2104-13922398210748_thumb.png

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...