Jump to content
Software FX Community

garbage instead of correct string


User (Legacy)
 Share

Recommended Posts

You need to select the appropriate character set and font in order to

display Unicode characters.

For more information check out the following KB articles and samples:

Samples:

http://support.softwarefx.com/samples/cfxie/internationalization/charset.asp

Articles:

Q1462021. Double byte characters (DBCS) are lost when creating active chart

--

FP

Software FX, Inc.

Link to comment
Share on other sites

Sorry but you are wrong.

In my unicode project in MS Visual Studio 6.0 I can create a dialog and set

for it font "Tahoma" (witch is unicode font and allows using various

charset) and I can use API function for unicode SetWindowTextW and

GetWindowTextW and display correct string on various languages.

Thanks for your answer

Link to comment
Share on other sites

SetWindowTextW is a Windows NT Only Function.

Chart FX is designed to work in both Windows NT and Windows 9x therefore the

strings are converted to MBCS.

This conversion is done using the current threads Code Page. which means it

will use the default codepage for your OS version (e.g. Japanese if your

Windows version is in Japanese).

Same applies for the Cha Set, we use the Default Charset for the system. If

you want to use a different one you need to specify it.

What CharSet are you setting to the font you are assigning to Chart FX ?

What Font are you using ?

Can you please attach the code you use to set the font to the chart.

--

FP

Software FX, Inc.

Link to comment
Share on other sites

No, but the current version SUPPORTS Unicode. You can display ANY string in

ANY language.

You may be making a mistake when assigning the font to the chart.

1) Is your Windows Version in the same language than the language you are

trying to display ?

2) Can you post the code that you use to set the chart's fonts ?

--

FP

Software FX, Inc.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...