Jump to content
Software FX Community

ChartFX IE 2000 keeps displaying a dummy chart


User (Legacy)
 Share

Recommended Posts

Hello

I have read the other thread from 26 february 2004. I have exactly the same

symptoms but the solution that seemed to help Devin Richardson does not make

a difference for me. Everytime I show the graph, a new chw file is created

in the cfxtemp folder, but the graph still just generates the dummy chart

instead of using the data I submit to the control. I also have the two

writer dll's.

I have just upgraded with the latest service packs from the support site,

but this still does not work.

My x-axis is also from 1 to 5

My y-axis is also from 0 to 100

I also have the virtual directory with the correct permissions.

The data I submit is very simple, like

2, 5

5, 200

9, 700

I create the graph like described in the documentaiton.

...I

set rs = ado.OpenRecordSet("select asfdsaf from sadf asf ")

Set chart = Server.CreateObject("ChartFX.WebServer")

Chart.RgbBk = RGB(255,255,255)

Chart.Chart3D = False

Chart.TypeMask = CT_HORZ

Chart.DataType(0) = CDT_XVALUE

Chart.DataType(1) = CDT_VALUE

Chart.DataType(2) = CDT_VALUE

chart.AdoResultSet rs

GetChart = chart.GetHtmlTag(351, 300, "ActiveX")

...

The constants are taken from the file CfxIE.inc

CT_HORZ = 512

CDT_XVALUE = 3

CDT_VALUE = 2

CDT_VALUE = 2

Please help. Any ideas is very appreciated. Thank you.

Best regards

Soren, Denmark

Link to comment
Share on other sites

Maybe your virtual directories are messed up.

Do a View Source of the resulting page, look at the datapath property and

check, by copy-pasting this url in your explorer address bar, if the url is

correct.

If it is not it might be due wither to configuration setting sin your IIS,

permissions or incorrect setting in your CfxSrv.ini, specifically the

Relative and Absolute settings.

--

FP

Software FX

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...