Jump to content
Software FX Community

I am install the chartfx internet 5.5 on windows 2003 - Failed to download License


Recommended Posts

I find the message .....

Internet Explorer shows a "Failed to download license" message inside the chart

Description:

ChartFX Internet was not able to download the license file

Resolution:

- Check that a file named CfxIE.lic is located on your webserver at (WWWRoot\License) for ChartFX IE 2000 users or (C:\Program Files\CfxIE\License) for ChartFX Internet 5.5 users.

- Check that the NT file permissions on this folder (License) allows Read access to the user impersonated by IIS (typically IUSR_MachineName)

- Check in your web server configuration that you have a virtual directory called "License" pointing to the "WWWRoot\License" or "C:\Program Files\CfxIE\License" folder. If you are hosting multiple web sites please make sure that you create the "License" virtual directory in each of the web sites that will use ChartFX.

 

but , I try to bug fix .... faile ,.... what is bug fix software will download ??

I try long time.... can you help me ?

Link to post
Share on other sites

Are the ChartFX Internet 5.5 virtual folders properly set on IIS? Please follow the information below to ensure that the virtual folders are properly set and that you set the MIME Types:

There are some known issues regarding Chart FX and Windows Server, here are some articles referring to that topic:

http://support.softwarefx.com/ShowArticle.aspx?Type=KB&Product=CfxIE&Source=http://support.softwarefx.com/kb/143/1/059.htm - This talks about adding the mime types.

http://support.softwarefx.com/ShowArticle.aspx?Type=KB&Product=CfxIE&Source=http://support.softwarefx.com/kb/143/2/058.htm - This talks about setting the virtual folders.

Due to the "lock down" nature of Windows Server, IIS is configured to not server any unknown file types. As a consequence, IIS6 returns 404 - File Not Found for some of the file extensions we use with our component or a license error much like the one you have received. You will need to add .chw and .lic extensions to the list of mime types manually. If not, IIS will not serve any files with those extensions.

Steps:

- Internet Information Service Manager

- Right click "Default Web Site" and select properties

- HTTP Headers page

- Click on the "MIME Types" button

- Click new

- Set the extension to .chw and the mime type to "application/octet-stream"

OK ...

Also add:

extension: .lic, type = text/plain

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...