Jump to content
Software FX Community

How to run ChartFX PSS Service on a different port?


dbodine
 Share

Recommended Posts

Our servers with McAfee Enterprise 8.7x installed are running into a problem - the McAfee Framework service installs on TCP port 8082 (or at least it does in our environment), which is the exact same port on which the ChartFX PSS service runs for ChartFX 7.0.   When I have the McAfee service stopped, I am able to start ChartFX PSS service and charts render fine. With McAfee running, I cannot even start the PSS service. Our IT department has informed me that they cannot change the port for McAfee and that it must remain installed, so we have to change the port number for PSS.  I attempted to do this as per the instructions in ChartFX documentation and reading support replies in the forums, and so far - no charts, just an image placeholder with a red X (we do not use the .NET control). Here are all the steps I have taken to date (and this is tested on multiple machines so IIS version and OS are unimportant):

1.  We use forms authentication and have made the PSS service part of the web application by adding the HttpHandler to our web.config and setting up a ChartFX.WebForms.config in the /bin folder of our application, like so:

<chartfx>  <PssOutput>   <ServiceURL>tcp://localhost:8082/PssService</ServiceURL>   <HandlerURL>/CustomerCare</HandlerURL>   <RootURL />   <RootURLFile />   <Authenticate>true</Authenticate>  </PssOutput></chartfx>

...using the default port 8082 this works fine.

2. I changed the port number to 8090 in the above ChartFX.WebForms.config

3. I also changed the port number in C:\Program Files\Chart FX for Visual Studio 2005\PSS\ChartFX.PSS.Service.exe.config to 8090 so that file looks like this:

 <configuration>  <!-- You may customize PSS by uncommenting and modifying the settings below   See Programmers Guide or KB article Q7621004 / http://support.softwarefx.com/kb/762/1/004.htm   for more details.  -->

  <appSettings>   <add key="EventLogLevel" value="Trace" />   </appSettings>

  <system.runtime.remoting> <application>  <service> <wellknown mode="Singleton" type="ChartFX.Pss.ServiceContact, ChartFX.Pss.Service" objectUri="PssService" />  </service>  <channels> <channel port="8090" ref="tcp"/>  </channels> </application> </system.runtime.remoting></configuration>

4.  Finally, I added a key to the appSettings inside C:\Program Files\Chart FX for Visual Studio 2005\ChartFX70\PSS\web.config so it looks like this:

<configuration> <system.web> <httpHandlers> <add verb="*" path="ChartFX.aspx" type="ChartFX.Pss.HttpHandler,ChartFX.Pss.HttpHandler" /> </httpHandlers> </system.web> <appSettings> <add key="Channel" value="System.Runtime.Remoting.Channels.Tcp.TcpChannel,System.Runtime.Remoting" /> <add key="ServiceURL" value="tcp://localhost:8090/PssService" /> </appSettings></configuration>

5.  When I run charts, the image URL creates correctly as /CustomerCare/ChartFX.aspx?xxxx...etc but there is only a red X placeholder where the image should be.

6.  If I browse directly to the image URL in the browser I get a "bad request" 400 error and despite setting the EventLogLevel to Trace there is absolutely nothing helpful in the Event log or the IIS log files.

7. The PSS service is set up properly in IIS, as proven by the fact that it works when the port is set to the default 8082.

I have also restarted the machine and all services several different times - and updated ChartFX 7.0 to the latest patch level (7.0.3754.x) to no effect whatsoever.   Currently we have the PSS service completely disabled, but I'm worried about the impact on performance as the application scales up.

Am I missing something here or doing something wrong?  Or is there a bug in the PSS service where it doesn't allow anything other than port 8082?

Thanks - dB

Dennis BodineSenior Software Engineer, Itron, Inc.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...