Jump to content
Software FX Community

Blank screen while using .Net Chart


Nemi
 Share

Recommended Posts

I am using Chart FX 6.2 for .Net to display chart as .Net control for interactive chart. Instead of displaying the chart, I get a blank screen. Please check the attached image. I have tried various options mentioned in various forums but with no luck. I am able to render the chart as an Image but not as a .Net control.

Initially I got this error with Chart FX 6.0. Then, I upgraded to Chart FX 6.2 using Chart FX 6.2 installer available in Chart FX web site, but I still get the same error.

The server configuration is Windows Server 2003 with .Net 2.0 framework.

Following are the options I tried so far.

1. Added extension .lic and .chw to the default site property settings

2. Added .lic and .chw to MIME types with appropriate content types

  .lic - text/plain

  .chw - application/octet-stream

3. I have given full permission to all the users to Default Web Site

4. I have also given full rights for IUSR account to ChartFX folder which has the Temp directory.

5. The .chw file is getting generated properly when I try to access my Chart.

6. When I tried to browse the .chw file (for example http://localhost/ChartFX62/Temp/CFT0309_0134390C9D9.chw), I get the option to save/ open the file. (which I guess is correct)

7. I have also added the website to the list of trusted sites

8. Enabled Full trust to all Intranet, internet and trusted sites for .Net 2.0

This same application is working when I am running from my local development machine but getting a blank screen when the application is deployed to production server.

 Please let me know if any other setting is missing on the server. Appreciate your help.

Thanks

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...