Jump to content
Software FX Community

Unable to use on Windows Web Server 2008


Recommended Posts

I implemented the ZoomScrollBar feature on my web site using ChartFX 7.0.  Then after installing ChartFX 7.0 on a web server I got the error "System.FormatException: Invalid File Format. The file you are trying to import is not a valid Chart FX file".

I am using VS2008 on Windows Server 2008.

I looked through the forum posts and verified that the assemblies in my project bin folder have same versions as the assemblies in the "Program Files\Chart FX 7\ChartFX70\Download", so I do not have a version mismatch issue.

Since the ZoomScrollBar feature requires full trust, I installed ChartFX.WebForms.dll into the GAC to give it full trust and I still got same problem.

One of the posts mentioned that they updated service pack but they don't mention what service pack, so I installed ASP3.5 SP1 and still got same problem. Then I thought maybe I have to update ASP2.0 service pack then went to Microsoft's download center and it turns out it that ASP2.0 service pack is not supported on Vista operating system.

I hope I can get help on this because I really preferred your tool over others but if I can't run it, then I can't buy it. 

 Following is the exception error log:

See the end of this message for details on invoking

just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************

System.FormatException: Invalid File Format. The file you are trying to import is not a valid Chart FX file.

at ChartFX.NetIEClient.Chart.c(Boolean A_0, IPersistBase A_1)

at ChartFX.NetIEClient.Chart.a(DownloadEventArgs A_0)

at ChartFX.NetIEClient.ao.a(DownloadEventArgs A_0)

************** Loaded Assemblies **************

mscorlib

  Assembly Version: 2.0.0.0

  Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)

  CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll

----------------------------------------

System

  Assembly Version: 2.0.0.0

  Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)

  CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll

----------------------------------------

ChartFX.NetIEClient

  Assembly Version: 7.0.2893.24916

  Win32 Version: n/a

  CodeBase: http://localhost:2257/SmartCom/chartfx70/download/ChartFX.NetIEClient.dll

----------------------------------------

System.Windows.Forms

  Assembly Version: 2.0.0.0

  Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)

  CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll

----------------------------------------

ChartFX.NetIEClient.Base

  Assembly Version: 7.0.2893.24781

  Win32 Version: n/a

  CodeBase: http://localhost:2257/SmartCom/chartfx70/download/ChartFX.NetIEClient.Base.DLL

----------------------------------------

System.Drawing

  Assembly Version: 2.0.0.0

  Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)

  CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll

----------------------------------------

Accessibility

  Assembly Version: 2.0.0.0

  Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)

  CodeBase: file:///C:/Windows/assembly/GAC_MSIL/Accessibility/2.0.0.0__b03f5f7f11d50a3a/Accessibility.dll

----------------------------------------

ChartFX.NetIEClient.Adornments

  Assembly Version: 7.0.2893.24805

  Win32 Version: n/a

  CodeBase: http://localhost:2257/SmartCom/chartfx70/download/ChartFX.NetIEClient.Adornments.DLL

----------------------------------------

Microsoft.mshtml

  Assembly Version: 7.0.3300.0

  Win32 Version: 7.0.3300.0

  CodeBase: file:///C:/Windows/assembly/GAC/Microsoft.mshtml/7.0.3300.0__b03f5f7f11d50a3a/Microsoft.mshtml.dll

----------------------------------------

System.Configuration

  Assembly Version: 2.0.0.0

  Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)

  CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Configuration/2.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll

----------------------------------------

System.Xml

  Assembly Version: 2.0.0.0

  Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)

  CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll

----------------------------------------

System.Data

  Assembly Version: 2.0.0.0

  Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)

  CodeBase: file:///C:/Windows/assembly/GAC_32/System.Data/2.0.0.0__b77a5c561934e089/System.Data.dll

----------------------------------------

************** JIT Debugging **************

To enable just-in-time (JIT) debugging, the .config file for this

application or computer (machine.config) must have the

jitDebugging value set in the system.windows.forms section.

The application must also be compiled with debugging

enabled.

For example:

<configuration>

  <system.windows.forms jitDebugging="true" />

</configuration>

When JIT debugging is enabled, any unhandled exception

will be sent to the JIT debugger registered on the computer

rather than be handled by this dialog box.

 

 

Link to post
Share on other sites

Hi,

 I do not believe this has anything to do with the fact that you are running on Windows Server 2008, however there may be a problem with the assemblies in the GAC. Please note that the assemblies that need full trust are the the client asemblies (the ones that run on the browser). In order to let the client control run with full trust you need to give Full trust to the zone in which the web application is runing. If you are testing the application on localhost, you are most likely in the "Local Intranet" or the "Trusted Sites" zone.

First of all, please remove all Chart FX assemblies from the GAC.

Then, to give full trust to that zone you need to go to Administrative Tools > Microsoft .Net Framework 2.0 Configuration. Once there, expand the "My Computer node". Click on Runtime Security policy. On the Right pane, inside the Tasks Box, click on Adjust Zone Security. Follow the wizard and adjust trust accordingly. 

Try the app again and let me know if oyu continue to run into issues.

 Regards,

TT 

 

post-5463-13922406427007_thumb.png

Link to post
Share on other sites

Hi,

I already looked for "Microsoft .Net Framework 2.0 Configuration" and could not find it under Control Panel.  Note that this server does not have ASP.Net 2.0 installed in it.  It only has ASP .Net 3.5.  Since this feature was not available, I wanted to at least install runtime libraries of .Net 2.0; however, Microsoft does not have any .Net 2.0 for Vista.

Link to post
Share on other sites

One more thing that I would like to point out is that both, my server and my client machines use Windows Vista and neither shows the option to configure .Net Framework.  I will dig a little more on Microsoft's site to see if they have something for asp 3.5.

Link to post
Share on other sites

OK.

 Unfortunately, for framework 2.0 and above, Microsoft decided to limit availability of the Framework configuration tool to Visual Studio Users only. If the client machine does not have visual studio installed, you will not be able to change trust settings through the configuration wizard. You will need to use the caspol tool from the command line:

cd C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727 caspol -machine -chggroup Internet_Zone FullTrust

 Make sure to change the zone accordingly (Intranet_Zone, Trusted_Zone).

Please try this out and let me kno how it goes.

TT

Link to post
Share on other sites

Thanks, now I can view the chart in my browser; however, I don't like the idea of setting FullTrust to the entire "Internet_Zone". 

Now that I am able to load the graphic, the problem is that the first time it loads, it takes about 25.  With other chart tools it takes just about a second to load, of course, other tools don't have the zoom feature that I want in ChartFx but is it possible to speed up the first time the chart loads?  My data just has 5 data points.

Link to post
Share on other sites

> Thanks, now I can view the chart in my browser; however, I don't like the idea of setting FullTrust to the entire "Internet_Zone".  

You can also assign full-trust to a specific control.

Here si the caspol command to add full trust to all Software FX Assemblies (that big number is SoftwareFX's strong name which can be obtained using sn.exe):

caspol -q -m -ag All_Code -strong -hex 00240000048000009400000006020000002400005253413100040000010001003d35b05ac523a5dbbdb65b6158a5de0eb20d2519ff6956ae294fcada2ca2d354428a1163f56e8294c277132ba0759d85b87df88169b63f8519882738bba48b91260f3e090252de6da366e8f16ee32b4c816cd9f6a466232d57e55bb92cae3e4a6e01b4c0b41241819d25d5dcbf6f1cddb0b7abbae608cb541106e8855f0bceb6 -noname -noversion FullTrust -n "Software FX" -d "FullTrust for all Software FX Assemblies" -exclusive on

>

Now that I am able to load the graphic, the problem is that the first time it loads, it takes about ...

This is inherernt to the way IE loads .NET Controls.

The following thread should shed some light on the problem and how to mitigate it.

http://community.softwarefx.com/forums/t/274.aspx

 

Link to post
Share on other sites

Hi, thanks for looking more into it.  I could not test on either of my 3 PCs because they were already set to have full trust so I gave the script to a friend and it didn't work.  I verified that the command did not give any errors and executes successfully but the scrolls don't work probably because of the full trust issue.

Link to post
Share on other sites

I think the reason why the script didn't work is because my friend's PC must have security settings set by IT to prevent him from providing full trust because we tried modifying manually by opening "Internet Options" but the most he can provide is "Medium trust".  He does not have an option to change to "Full Trust".  So I guess you can disregard previous reply but problem is still being able to provide trust.  I guess we have to elevate the issue to IT and ask them to allow full trust to trustFx component.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...