Jump to content
Software FX Community

The device is not ready.


Tetsuo
 Share

Recommended Posts

I am just setting up my local dev web server after a windows reinstall. OS=Vista x64.

Upon loading any page with a chart on it, I get this:

The device is not ready.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.IO.IOException: The device is not ready.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:

[IOException: The device is not ready.]   System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath) +7712840   System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy) +1162   System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options) +65   System.IO.StreamReader..ctor(String path, Encoding encoding, Boolean detectEncodingFromByteOrderMarks, Int32 bufferSize) +87   System.IO.StreamReader..ctor(String path) +30   System.IO.File.OpenText(String path) +35   SoftwareFX.ChartFX.Internet.Server.TextProvider.Open(String fileName) +12   SoftwareFX.ChartFX.Internet.Server.1C.GG(Int32 1MN, Int32 1MO, 1B 1MP) +118   SoftwareFX.ChartFX.Internet.Server.1C.G8(1B 1MD) +53   SoftwareFX.ChartFX.Internet.Server.Chart.SaveViewState() +165   System.Web.UI.Control.SaveViewStateRecursive() +187   System.Web.UI.Control.SaveViewStateRecursive() +106   System.Web.UI.Control.SaveViewStateRecursive() +106   System.Web.UI.Page.SaveAllState() +168   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +1099
 

I know the process has access to the temp directory because that was the previous error & I fixed it.

I ran process monitor, I don't see any failures.

5884 2:48:45.8264056 PM w3wp.exe 4968 CreateFile C:\inetpub\wwwroot\tet-sysadmin.company.com\chartfx62\temp\CFV0905_024845320DA.CHW SUCCESS Desired Access: Generic Read/Write, Disposition: Create, Options: Synchronous IO Non-Alert, Non-Directory File, Open No Recall, Attributes: n/a, ShareMode: , AllocationSize: 0

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...