Jump to content
Software FX Community

Evenst not firing for annotations.


Recommended Posts

 Dear allfirst of all I am sorry that I am forced to use your activex control. I have not seen a worst chart control in my life.I lost a huge amount of time now trying to make a Circle object really a Circle. I want to be able to add Circle objects and restrict them to be cirlces as your Circle object is actually an ellipse.Anyway...there is no flag in the object to that so I decided to change the size on the move/resize events, but that is also not possible. I use the damned component from QT and I connected to the events, but the only event that gets fired is  selectionChanged()I hope it is again one of those damned flags you have that I must set somewhere in order to receive all the event (The help is awful too)Any help will be highly appreciated.I hope at least you will be quick enough in this forum.Thank you in advance

And please if you delete my post again I will take the time to find all sites and articles where your component is listed and write a "Review".

10x

Link to post
Share on other sites

This community forum is not the appropriate place for this kind of rants. This is a community of developers helping developers and this is certainly not the way you will get help from others.

If you have a complaint or want to report a bug I suggest you contact Software FX support directly via e-mail or phone.

Use of abusive language may result in messages being deleted and your account being closed.

Link to post
Share on other sites

Please post the code you are using to attach to the events (the ones not firing).

If possible, post a sample application that replicates the problem, this will allow us to determine the cause of the problem more quickly.

Link to post
Share on other sites

 Hello

I told you that I use the component from QT in a big app and sending a sample will be a bit difficult.

Code in general is:

 

//Create an annotation list

measureAnnotList.CreateInstance(__uuidof(AnnotationX));
chart->AddExtension((IUnknown *) measureAnnotList);
measureAnnotList->PutToolBar(FALSE);

//Create a handler for the events:

AnnotationsEventHandler *pAnn = new AnnotationsEventHandler((IUnknown *) annotationList);
 

/The event handler class:




AnnotationsEventHandler::AnnotationsEventHandler(IUnknown* intf, QObject* parent, const char*  name)
: QObject(parent, name)
{
pAnnotationsEventHandler = new QAxObject ((IUnknown *) intf,this);
connect( pAnnotationsEventHandler, SIGNAL( signal(const QString&,int,void*) ), this, SLOT( annotationsSignalDispatch(const QString&,int,void*) ) );
}

// slot
void AnnotationsEventHandler::annotationsSignalDispatch 
(
const QString& signalName,
int   argc,
void*   argv
)
{
qDebug("CALLING AnnotationsEventHandler() - SIGNAL: "+signalName);

}

 

Let me clarify that 

connect( pAnnotationsEventHandler, SIGNAL( signal(const
QString&,int,void*) ), this, SLOT( annotationsSignalDispatch(const
QString&,int,void*) ) );


Catches ALL the events of an activex control so they are relayed to the method 
annotationsSignalDispatch(const
QString&,int,void*)

unfortunately the only event that is received is   HRESULT SelectionChanged ( );
while the one i have in tlh are:

struct __declspec(uuid("4b6f58cf-365a-11d1-8fd4-00aa00bd091c"))
_AnnotEvents : IDispatch
{
  //
  // Wrapper methods for error-handling
  //

  // Methods:
  HRESULT LButtonDblClk (
  struct IAnnObject * pObj,
  short * nRes );
  HRESULT ObjectCreated (
  struct IAnnObject * pObj );
  HRESULT ExecuteCommand (
  short nID,
  short * nRes );
  HRESULT SelectionChanged ( );
  HRESULT StartMoving (
  int Left,
  int Top,
  int right,
  int bottom );
  HRESULT OnMoving ( );
  HRESULT EndMoving ( );
  HRESULT ObjectDeleted (
  struct IAnnObject * pObj,
  short * nRes );
};

So if my code catches the selectionchange event then it is implemented properly. The question is why I do not receive the rest of the events that actually I am more interested in.

Do I need to set a flag or something for the  measureAnnotList ?

Thank you in advance.

Link to post
Share on other sites

We are currently investigating this issue. Because you didn't provide a repro case, I forwarded the request to our support team so that they can create one. I will post back with their findings. You may want to contact Support directly to open a support ticket and be automatically notified when the issue gets resolved.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...