Jump to content
Software FX Community

Tooltips Disappear in Windows XP


Recommended Posts

A user reported a problem that I have confirmed.  If they click a few times

with their mouse in the chart area, the tool tips that display individual

bar values disappear (i.e., the tips no longer pop up when the user hovers

their mouse pointer over a bar). Once the tool tips disappear, they don't

come back even if the graph is refreshed. They have to shut down the

program and restart it before the tool tips will reappear.

If the user does not click in the chart area, the tool tips in the chart

work OK.

I have confirmed the problem - it seems to be related to Windows XP, as the

problem cannot be duplicated under Windows 2000.

FWIW, it appears that I'm using version 5.0.9.0 of the cfx4032.ocx, and the

same version of the cfx4032.dll.

GG

Link to post
Share on other sites

We are no aware of this problem and it does not happen in any of our XP 

machines, maybe we need to know specifically what needs to be done to make

this happen and what type of chart it has to be.

Dos this happen with all the chart ? can you reproduce this problem with a

simple application that has just one default Chart ?

Also, the version you are using is quite old, you may want to download the

latest Service Pack from our support site.

--

Francisco Padron

www.chartfx.com

"Gary German" <garyg@NOSPAMXshastasoftware.com> wrote in message

news:i2uE4RMmFHA.1848@webserver3.softwarefx.com...

>A user reported a problem that I have confirmed. If they click a few times

> with their mouse in the chart area, the tool tips that display individual

> bar values disappear (i.e., the tips no longer pop up when the user hovers

> their mouse pointer over a bar). Once the tool tips disappear, they don't

> come back even if the graph is refreshed. They have to shut down the

> program and restart it before the tool tips will reappear.

>

> If the user does not click in the chart area, the tool tips in the chart

> work OK.

>

> I have confirmed the problem - it seems to be related to Windows XP, as

> the

> problem cannot be duplicated under Windows 2000.

>

> FWIW, it appears that I'm using version 5.0.9.0 of the cfx4032.ocx, and

> the

> same version of the cfx4032.dll.

>

> GG

>

>

Link to post
Share on other sites

"Software FX Support" <noreply@softwarefx.com> wrote in message

news:UD1e9ZimFHA.1828@webserver3.softwarefx.com...

> We are no aware of this problem and it does not happen in any of our XP

> machines, maybe we need to know specifically what needs to be done to make

> this happen and what type of chart it has to be.

>

> Dos this happen with all the chart ? can you reproduce this problem with a

> simple application that has just one default Chart ?

>

> Also, the version you are using is quite old, you may want to download the

> latest Service Pack from our support site.

I've been meaning to do that, and in an effort to resolve the problem, I

tried to do that yesterday. But, I could not figure out where on your site

to get the update. I just tried it again, and I realize what's happening -

your Support page does not work in the Firefox browser!

I've switched to Internet Explorer, and I can now see the "toolbar" along

the left side of the page. But, I seem to still be having problems. I

start by going to this web page:

http://support.softwarefx.com/chartfx/

Next, I click on the Service Pack option on the left. Then, I click on

"Latest Service Pack". When I click on "Download", it seems to work for a

bit, then I get a cryptic error message popup with a caption of "Error", and

the message "Missing IfxVer setting or file not found". When I then clicked

on "Install", it crashed the Internet Explorer browser.

The download does seem to download a file named "CfxServicePack.exe",

despite the error. But, when I try to run that file, it says "Downloading

Application Info (GlobalUpdateFX.xml)" but never does anything else. The

"Install" and "Download" buttons are grayed out.

Needless to say, this is very frustrating.

FWIW, I also just noticed that when I run Cfx98Info.exe, it says "Not

Licensed" in the area labeled "This product is licensed to"! But, this is

weird because I've been using your tool (and recommending it to clients and

colleagues) for several years now. And the serial number and license

strings are shown OK. Also, I never see any "not registered" warnings when I

run my programs, nor have I had any reports of this from users. So,

something is clearly amiss on my system.

Please help - I would like to get the latest service pack and include it in

my next release - hopefully it will resolve the Win XP issue I reported.

GG

>

> --

> Francisco Padron

> www.chartfx.com

>

>

> "Gary German" <garyg@NOSPAMXshastasoftware.com> wrote in message

> news:i2uE4RMmFHA.1848@webserver3.softwarefx.com...

> >A user reported a problem that I have confirmed. If they click a few

times

> > with their mouse in the chart area, the tool tips that display

individual

> > bar values disappear (i.e., the tips no longer pop up when the user

hovers

> > their mouse pointer over a bar). Once the tool tips disappear, they

don't

> > come back even if the graph is refreshed. They have to shut down the

> > program and restart it before the tool tips will reappear.

> >

> > If the user does not click in the chart area, the tool tips in the chart

> > work OK.

> >

> > I have confirmed the problem - it seems to be related to Windows XP, as

> > the

> > problem cannot be duplicated under Windows 2000.

> >

> > FWIW, it appears that I'm using version 5.0.9.0 of the cfx4032.ocx, and

> > the

> > same version of the cfx4032.dll.

> >

> > GG

> >

> >

>

>

Link to post
Share on other sites

I just went to the support site and try installing the Service Pack and 

everything worked fine, like it is the case many times, it always works in

the dev. machine !

We have been in the process of moving the office in the last couple of days

so maybe something was broken at some point.

Please try going to the support site again and when going to the Service

Pack screen simply click on "Install", no need to download unless you are

not in the computer where Char FX is installed.

As for the Cfx98Info.exe message, no need to worry about it, you probably

have an old version of it but this will not affect the operation of the

product.

If you continue to have problems please contact Software FX Support, they

can give alternative ways of downloading the service pack.

--

Francisco Padron

www.chartfx.com

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...