Jump to content
Software FX Community

X-axis start values


Recommended Posts

I want to have my X-axis begin at a non-whole number value, such as 48.5.

However, when I do this it seems to just round my number off and shift

everything left. In the chart below, I would like to remove the gap at the

left of the series, but if I do that the graph will be inaccurate (the data

should start around 48.5). I hope this makes since... thanks very much for

any help you can provide.

Eric

begin 666 B12345-1-CFT0309_1734192B9.png

MB5!.1PT*&@H````-24A$4@```G$```%>" ,```#=0;ET```"Q%!,5$4```"

M````@ " @ ```(" `( `@(# P," @(#4T,B @("@H*2 @( ```#_````_P#_

M_P```/__`/\`______^9F?^9,V;__\S,__]F`&;_9F8`9LS,_\S_S#-FF9G_

MS/_,S,QFF6;_9IF9F0`S_V;,S/^9F9G,S)G,F<R9S)G,,S.9F<S,F0#_9@#_

M_P#,,YEF_YD``)G,9IG_`&;,F9D`_____YF99F8`_P#,_YG,`/\`9O__S)G_

M,V8S,V9FF3.9S,R9S&;_F9EF9F8``````#,``&8``,P``/\`,P``,S,`,V8`

M,YD`,\P`,_\`9@``9C,`9F8`9ID`F0``F3,`F68`F9D`F<P`F?\`S ``S#,`

MS&8`S)D`S,P`S/\`_S,`_V8`_YD`_\PS```S`#,S`&8S`)DS`,PS`/\S,P`S

M,S,S,YDS,\PS,_\S9@`S9C,S9F8S9IDS9LPS9O\SF0`SF3,SF68SF9DSF<PS

MF?\SS `SS#,SS&8SS)DSS,PSS/\S_P`S_S,S_YDS_\PS__]F``!F`#-F`)EF

M`,QF`/]F,P!F,S-F,V9F,YEF,\QF,_]F9@!F9C-F9IEF9LQF9O]FF0!FF<QF

MF?]FS !FS#-FS&9FS)EFS,QFS/]F_P!F_S-F_V9F_\QF__^9``"9`#.9`&:9

M`)F9`,R9`/^9,P"9,S.9,YF9,\R9,_^99@"99C.99IF99LR99O^9F3.9F6:9

MS "9S#.9S/^9_P"9_S.9_V:9_YF9_\R9___,``#,`#/,`&;,`)G,`,S,,P#,

M,V;,,\S,,__,9@#,9C/,9F;,9LS,9O_,F3/,F6;,F?_,S #,S#/,S&;,_P#,

M_S/,_V;_``#_`#/_`)G_`,S_`/__,P#_,S/_,YG_,\S_,___9C/_9LS_9O__

MF0#_F3/_F6;_F<S_F?__S #_S&;_S,S__S/__V;T=)[N````)G1%6'13;V9T

M=V%R90!#:&%R=$98($E%+B!3;V9T=V%R92!&6"P@26YC+CB_XT\```YC241!

M5'B<[9UIHJLH% ;Y^19P]IZ]937=W*@,3H!Z9*CJ?AF,$=&ZJ.$+,09 %P'0

M`^- %XP#73 .=,$XT 7C0!>,`UTP#G3!.- %XT 7C -=, YTP3C0!>- ER>-

M^P?P/XK&/;9D: B,`UTP#G3!.- EW;C?2],,)IC9?VESXE91,";)QIGIOS_;

MS'0OBWXFN(TF;A8%8Y)EG//(+%,%XR"'*T=5P3C()N/*P03MW#1)),FXC8_^

M8$PN&>=Y1QL':91=.3BI1# .<KAP'C=]@]]L?3H23=PJ"L8DZZB:,_FT*!B1

M[_<;3BCH<\ X2.3[(YA&+Q<\Q/>[)1S&P2-\G6_TY,/3?(/F#>/@4;[QT13C

MX#&^*]T$X^ I-G43C(-'V---, [N9]\V2V8OU]RSM1_W)0,\-L>Z279/OORZ

M3&6WTYZ>_)$YU4VR,\#B&2>"<;!P<.H6D)L=F70R3C^,@V3=)#N1*<$_,L @

M6;I)OG&>362 (>W4+2#WRL$WC@SPZ&3K)@498/>8#/#0Y!U+'62 H8!2W>2.

M/@>,&XT+N@F]7)#))=LL& ?I7-9-, Z2N4,WP3A(XMJI6P#&P1DWZB88!R?<

MJYM@'!QQMVV6XD2F\68FD=DC3^@FA8G,S0?TJ_;$0[K)A43F\@3C>N/V4[>

MHD2F(9'9+<_J)H6)3!%/*Q*9W?!]7#<I3&3^GI'([ D5VRPD,D%1-R&1"9JV

M64ADCHRV;182F</RAFY"+]>@O&2;!>.&XT7;+!@W%B_K)A@W$N_;9L&X,:C#

M-@O ]N@G&=4]5MEDPKF=JL\W"J*R]4EWC-L&HK#U2JVV6H@RPN\.X^JA9

M-RD=E54PKDXJM\U2F@$VT2T9X-=IP#9+80;8%XXVK@(:T4T*,\"A<!CW,NW8

M9BG*`/\^(R$#7 %MV68A`]PP[>DF9(";I4G;+/1RM4BKMEDPKC6:;=PF,*XE

M6K?-@G'-T(-N@G&-T(EM%HRKGHYLLV!<W72FFQ3T.9R%+TEDWD9_MEDR^U5/

MNU#I5[V'/FVS9"8R_7C2_ CC[J9?W:3H>PX8]R1=VV;)S,>Y7(@7"":1>1/=

MVV8I,T[\=HXV[A:&T$TN73F0R+R-46RS7/ATA$3F/0QDFX5$YJN,U+A-D,A\

MC0%ML]#+]0Z#ZB88]P;CVF;!.%W&MLV"<8J@FV"<&M@V@7$*8)L'QCT-NH5@

MW)-@VQHRP(^!;9N0`7X&=-NC. ,L[A'&16#;`6498'?HG&\P;@;=COA\/N&$

MM$1FH!498 ]T.^+S(YB69QP9X !T.^+SV1*.#' I7"D<\7&0`;X#=#O"UTW(

M`%\'W8Z(=!,RP!?!MB-6MEGHY2H'W0Y8-VX3&%<(NAVPJYM@7!GH=L"1;H)Q

M^7"E<,");1:,RP+=#DC033 N!W0[($TWP;ADL.V 5-LL)#)30+=]DANW"1*9

MIZ#;/KFZ26$B4Y9'W1N';OL4Z":%B4Q[/TV<;[HT#MUV*;/-<FF,S)X3F5R8

M[E.NFS JZS;HML\EW81163= MWTNVF8AD1F";;M<;=PF2&1ZH-LN-^DF)#(=

MZ+;+?;H)O5P3Z+;'K;99#HTS&2U8=E'5P)7"+K?K)L?&F?EJ\Y&B:N#[1;==

MGM!-SHR[M9&KS+@ONAWPC&V6(8W[8ML1#S5N$\.=QR';,<_J)F-=J]*TG?!Y

M7#<YO7+HY:B*;*=HV&;9-\Y,A"\UF '&ME-4&K>)TS;./6DP`XQL"2C:9CF^

M<O#:N.VD4L7&(5L"FHW;1'(;%XS**G4;1].6A+YMEG3CUOFX*C/ R);$"XW;

MQ"7C*LL`T[0E\IIMED/CXO.XBC/ R);(>XW;1 <98)JV9-ZVS7)RK>H?67=<

M?#.1B6SIO-ZX35SOR7_+.&S+H!+;+$UF1Y MAUH:MXGFC$.V+.JRS7+:Y_!8

M4?G0M.516>,VT4Y:"=FRJ-(V2S/&85LZ=39N$\D]^;<7E0NRI5&S;9:,7JZ;

MBX+[J;IQF\"X;FC -DMROZKKM3)+_U8;&> 1:*%QF\C,`/N]]PUD@,>@'=LL

M6<9YD[R@$L:]2$.-VT3F4749!WB>.-]@W LT9YLE<U36WWW8Q-65`1Z%]AJW

MB8SOJWK&!<+1QJG3JFV6Y.^K^AE@KVV;[s%.BV8;MXG,[W*YB&\]&>"!:-TV

M2\9(-Q5F@(>B!]WDCA$+,4Z!3FRS-)?('(^.;+-@7-UTIIL,.&)A0_1GFZ69

M1.9@]&F;)>/[JC<7!;OTJYMP'E<=7=MFP;B*Z-XV2[iQ7B)3IDXL$IDW,H1N

MDO%]U3"1&8Q;2+_J54:QS9+UB[Y>6L1/CV#<)0:RS7*<R%R]9.:.>HR[A9$:

MMXGC-B[Z/-BX>S^OE& <B<PU`]IF.3NJ>L\]XY:F;II &Y?+H+I)1AL7)#(E

M4 GC\AC7-DOF>=PRPW1.9U;A2Q*9AXQMFR7KFS4YDT^+&A!TDSM&NL&X)+!M

M@G%'%, V#XQ[&G0+P;@GP;8UZ:- W%U4[V#;-F2 G^"#;KM@W-U@VS'IOUI^

M=U$=\L&V<VCC;@+;$BGX[4'7=4H&^ >V99"5R'0II=DZ\G'(EDE1!MA]J7!L

MX["M@,RC*J.RSF!;(8S*6@"V7>"2<0-F@+E(N$KFE</JBD%D'..P[0X*/AWY

M>R*#98"Q[2[(`)^#;'=RO<^A;^.P[6[HY=H'VYX`X[;!MJ? N!5<)#P*Q@5@

MV^-@W *VJ8!Q?R";&AB';;KD]CDLW0W^S,TF,CF0ZI.;R/3&8VT\D8EM[Y"9

MR'1!8"\]TIYQV/8>V3WY$AXZYYMFC$.VE\G,QTU9$0GR2LTD,K&M`G*-^TLH

M!2FY1MHX;*N$["L'KXUK)9&);#5QX=.1)A*9V%8;/2<RL:U&.DUD(ENU=-C+

MA6U5TYEQV%8]_1B';&W0AW'8U@[M&X=M;=&T<<C6(,T:AVV-TJ1QV-8PQ;U<

MQIM9,0.,;*U3E 'V^^J7!\_WY&-;#Q1G@.>IHF4<MO5!40;8_<R#GG'(U@E%

M&>#?L_E&*0.,;7U0E '^/6LK`PR5,$(&&&JB]PPPU$;/&6"HD4XSP% M3?9R

M0<-@'.B"<: +QH$N& >Z8!SH@G&@R]BCLH(^XX[*"N]0E,C\/5AN,0[2*1N5

M53 ."BE-9,:W38S*"A50F,CTA:.-@PR*$IFA<!@'&11].C*-/TTB$_(AD0FZ

MD,@$7>CE`ETP#G3!.- %XT 7C -=, YTP3C0!>- E^RTTEG<EPPP')+9DW_:

M:4]//AR3FP&6T".,@TRRLR/N>PXB& ?99"8R?_?+0,!D@"&7,N/$;^=HXR"#

M"U<.562 G_LP!Y[APJ<CRAE@$S\QQHV##<W02@;8['-EL:!.*QE@A.N%5GJY

M]EQ#N-9HQ;B-\SAHDG:,@S[ .- %XT 7C -=, YT(9$)NI#(!%V*$YGS8\$X

MR*$LD>D.G?,-QD$:1?FX0*MTXP#^Q<'</./R$IFZJ+:H%%;,DXE,7?K:+_T6

M]F0B4Y>^]DN_A3V9R-2EK_W2;V%/)C(!UI"I!5TP#G3!.-#E0>-4KUP5"S/S

MA3N%%1;RV))%[],YS<*\3Q\IK*"0IXQ;?K909U/I%>9W]"D5%CYJO+!GC5,[

M'&@:9Q0;U"A"H5-8FT=5([K-SJ2WVEFC8F^>%Z%0*JS)-N[7(Z;8$CR_J?P"

MM8U3^T"A7>-$LXU3+4PUL1!%*#0*:_;*H>M/1Y0+TQIN1:5F? (,NF <Z()Q

MH O&@2X8![i@'.B"<: +QH$N& >Z8!SH@G$3VYLA9>,D;D"V\P^,^V$VC4C:

M-JD;D W]!\;]F(S[):R"[-/.P(UF?CSGU[R7HA$*^"D*'XS[X<9660VEXE[<

MO/5_A7:::+;>AG$_,.X/+X=F7#C(9;!=P'1;IN"=WML$XV(P[@\WB(]_1F>6

M.S\:>V3<QMLP+@3C++,I-QU5-]^&<3\PSK*T31E7#OX;XBN'S5DQ[@^,BS$[

MC]/?53[+"&"<S^K[!,D;YWQ&MO,/C -=, YTP3C0!>- %XP#73 .=/G?N+=_

M1 >&@C8.=,$XT 7C0!>,`UTP#G0Y_NU!]^+F7$<CZ9GE?DX[3O%8X[_[9.7\

M?.0-?QDNV+OS>E)]HB"26GW"Q>^_?>>5.%2:LP[G]8H>'6_DP^6<+.*TWGYL

M5J(]=+QF\1I<5RYAQ-&4^L2)3'^.Y^IC3/CWH&G<V6QW&[?\,6^D"UWXT O0

M_C5FP=>7_)BBF4=O-\'BH[9C7H:?D+RJG/_-ERA6&6RID_IXQBG69VV<65?!

M*V6K\* &?FK9;0$_>>J]?]E\\]O\12R+#K?6CEK3Y$^$J^.R@;T_:o>7[>V!

M64MOCP1-G!/7^V,__OJ3\4O.V4/?B&4GR5S^NK#D^L1K^'Q]3(17F9U2W(Z2

ML *+8A+MU74=PIG%KY._</=ZN+7V:OA;_UBX/^7FBLU_R7/I\Q-9YG%B^F]8

M7O?F]M?$G=[Y.SW47,RRP(P]% OW4R[:UDMM_-.WI/K$:_AT?6+AS&X5C*NC

M"5?=WV5^)?PJ^I5PF\,W:K7 H*;3S,;$6S6NC;W;;..\]3LR+BQYP[6EW&@/

M1?.MGR_%B03+.66SC9OW2EP;?[E)]?%>UZG/41L75<$$_T>%!ZONUL4$;X\K

M8[;KM&=<L%UV*K-;3W_]PF-!O(;NKWKKJ&K<G-M[*-Z_EX^JN]61\)"PJE%*

M?3:VK$)]/-GFBJRJX*^3V2C<VQ!SU8+*RL;3M7'14=6ON?$6N%?#(^/F]MN_

M<M@P;EEU5^*O6'^]W=1H#[E3> F+^]7,1"67LQCGG?8&!:?7QS\IUZK/L7'K

M=?+VF=/$WQ"!;^ZT(GX:&+4L,*J9"=X[.WEXY7 ?YO#IC4M6HI[ZW+ZKBKFT

M'K=68^M<\;;%O["Y>ZO/7=1C', I& >Z8!SHLOYT$>!1_@-4*RNN0MR2&P``

*``!)14Y$KD)@@@``

`

end

Link to post
Share on other sites

As a followup, I tried using:

ChartFX1.Axis(AXIS_X).AutoScale = False

to prevent the x-axis from rounding down, but that didn't seem to have any

effect. Also, we're using ChartFX 5.5.

thanks,

Eric

"Eric Yancey" <eyancey@ATTcavtel.DOTTnet> wrote in message

news:wM2DKaiBEHA.4080@webserver3.softwarefx.com...

> I want to have my X-axis begin at a non-whole number value, such as 48.5.

> However, when I do this it seems to just round my number off and shift

> everything left. In the chart below, I would like to remove the gap at

the

> left of the series, but if I do that the graph will be inaccurate (the

data

> should start around 48.5). I hope this makes since... thanks very much

for

> any help you can provide.

>

> Eric

>

>

>

>

>

>

Link to post
Share on other sites

Thanks for the info.  Is there anyway to prevent the rounding without

displaying the decimals? On our X-axis the values are ages and it looks odd

to have decimals as part of the age display.

Thanks again for your help,

Eric

"SoftwareFX Support" <noreply@softwarefx.com> wrote in message

news:D$R$VCtBEHA.196@webserver3.softwarefx.com...

> You need to set the number of decimals displayed in the X-Axis to be at

> least 1 (or more). For example:

>

> ChartFX1.Axis(AXIS_X).Decimals = 2;

>

> --

> FP

> Software FX

>

>

Link to post
Share on other sites

I'm sorry that I wasn't clear, what I'm saying is that I want to begin

graphing values at 48.5, but I don't want 48.5 displayed - I only want the

whole numbers displayed on the x-axis.

So if the first value I graph has an x-value of 48.3, I want the first

number shown on the x-axis to be 48. So even though the the range of

x-values may be from 48.3 to 52.7, the only numbers shown along the x-axis

would be 48,49,50,51, and 52.

I hope this makes it clearer. Thanks again for your help,

Eric

"SoftwareFX Support" <noreply@softwarefx.com> wrote in message

news:VZ48X0vBEHA.196@webserver3.softwarefx.com...

> I don't understand. You said:

>

> " want to have my X-axis begin at a non-whole number value, such as 48.5"

>

> So. You want who;le numbers but 48.5 is not a whole number !

>

> If you want to represent 48.5 you need decimals.

>

> --

> FP

> Software FX

>

>

Link to post
Share on other sites

But that's what exactly you have in the attached picture.

You have a chart starting at 48. Since your first value is 48.3, you have a

gap between 48 and 48.3 (0.3).

You are asking for an x-axis that has "48 49 50 ..." and that' what I see in

the picture.

Can you please attach a drawing of what you would like to see in relation to

the picture posted before.

--

FP

Software FX, Inc.

Link to post
Share on other sites

In the first chart there was a lot of white space between the left side of

the graph and where the values started. I would like to remove this white

space without rounding the values that are graphed and without displaying

decimals in my x-axis labes. Here is a screen shot of what I would like to

see:

Note that the x-axis starts at 48.x but the first x-axis label is 49. It

seems as though if I try to get chartfx to do this for me, it rounds the

numbers down to 48. In the first chart that I posted I plotted some

invisible points to push the data out to the correct position between the 48

and 49, but that resulted in the white space.

thanks for your patience while I explain this to you.

Eric

"Software FX Support" <support@softwarefx.com> wrote in message

news:YgHYGc3BEHA.2508@webserver3.softwarefx.com...

> But that's what exactly you have in the attached picture.

>

> You have a chart starting at 48. Since your first value is 48.3, you have

a

> gap between 48 and 48.3 (0.3).

>

> You are asking for an x-axis that has "48 49 50 ..." and that' what I see

in

> the picture.

>

> Can you please attach a drawing of what you would like to see in relation

to

> the picture posted before.

>

> --

> FP

> Software FX, Inc.

>

>

Link to post
Share on other sites

Ok. Now I understand. You have to admit this was all very confusing. You

said you wanted your labels to start at 48. No I see that what you really

want is to start the labels at 49.

Basically what you want is you X-Axis min to be 48.3 while the first label

is 49. So the first label is NOT at the Min.

Unfortunately this is not possible with the version of Chart FX you are

using, this is possible using Chart FX 6.0 or later through a flag (on by

default) called AutoFirstLabel as you can see in the attached image.

Using 5.x, you will have to either start at 48.3 and then have labels at

"odd" intervals, or keep that gap to the left of the chart.

--

FP

Software FX

Link to post
Share on other sites

You're right, in one of my posts I stated that the I wanted 48 to appear,

when clearly I do not.

Thanks for your patience and sorry for the confusion. Sounds like we need

to either upgrade to 6.0 or live with what we've got.

thanks again, I really apprecate it.

Eric

"SoftwareFX Support" <noreply@softwarefx.com> wrote in message

news:dwv$Wh7BEHA.200@webserver3.softwarefx.com...

> Ok. Now I understand. You have to admit this was all very confusing. You

> said you wanted your labels to start at 48. No I see that what you really

> want is to start the labels at 49.

>

> Basically what you want is you X-Axis min to be 48.3 while the first label

> is 49. So the first label is NOT at the Min.

>

> Unfortunately this is not possible with the version of Chart FX you are

> using, this is possible using Chart FX 6.0 or later through a flag (on by

> default) called AutoFirstLabel as you can see in the attached image.

>

> Using 5.x, you will have to either start at 48.3 and then have labels at

> "odd" intervals, or keep that gap to the left of the chart.

>

> --

> FP

> Software FX

>

>

>

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...