Jump to content
Software FX Community

Re: Problems with setting chart types

User (Legacy)

Recommended Posts

I just figured out that it is even more weired.

Having a line chart, and setting the first and third risers to a bar works

fine, but having a bar chart and setting the second and forth riser to a

line fails.

But ....

the problem only arises if you run in 3D mode. In 2D mode, it works fine....

But ....

it works fine 3D if you have clustering switched on ....

If you run it in 3D, unclustered mode, you can see that the control gets

confused. I have attached a screenshot that shows that quit nicely.

(weired.jpg). To see what the chart was before I set the second series to

line I included before_weired.jpg, and to see that the control has the right

data I included 2dmode-ok.jpg and 3dclustered-ok.jpg. This demonstartes that

the control has the right settings, but that it is confused somehow while in

3D, unclustered mode.

I don't want to code something like (in pseudocode)

if chart.gallery == bar and chart.3dOn and chart.notClustered then

chart.gallery = lines

for i = 1 to chart.series.count do

chart.series[i].gallery = bar

end for

end if

This is simply stupid, but would work I believe. (for those two types of

series, but what about the others??)

Hope it gets fixed soon!


Maybe someone of Software FX could confirm this to be a bug, and provide a

suitable workaround or a date when it will be fixed.


Stephan Klaffer

DecisionWorks Ltd.

London / UK

"SteveT" <stephent@compassadv.com> wrote in message


Did you solve this?

I tried it and did see the same problem you wrote about. However it seems

that in multitype mode the object would like to have the series of the same

type next to each other. When I did this BAR,BAR,BAR,LINES,LINES worked


I'd also mention that after I put similar series next to eachother I could

subsequently put them in any order and it graphed fine. Curious.


Stephan Klaffer <stephan.klaffer@decisionworks.co.uk> wrote in message


> Hi there


> I have a bar chart which as 5 risers per series. I would like to set the

> last riser group to have a line style. Doing this through the dialogs


> fine. Now I want to set the second riser as well to a line, the previously

> set line completely disappears. Why??


> I have attached 3 screen shots, chart1.jpg displaying the original chart,

> chart2.jpg the chart after setting the last series to line style and

> chart3.jpg shows the result after setting the second series to a line.


> Thanks


> Stephan Klaffer

> DecisionWorks Ltd.

> London / UK






Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...