Jump to content
Software FX Community

Exception occurred msg with GetHtmlTag


User (Legacy)

Recommended Posts

I have the same code deployed to numerous servers.  On only one of the

machines, we get the following error output to the browser:

An Exception Occurred: 'GetHtmlTag'

The line of code that blows up is in the ASP page as follows:

strChartTag = objChart.GetHtmlTag(600,400,"Jpeg")

Pls note that in this ASP page, this is the second call to GetHtmlTag. The

earlier call is the standard <%= objChart.GetHtmlTag("100%","100%") %>

As I said, this code works on a bunch of machines. This is the only one

that doesn't work. It is the newest of our installs.

Thanks!

Link to comment
Share on other sites

Replace (temporarily) "Jpeg" with "ActiveX", if this works fine (no

exception), it would indicate a problem in the image generation process,

compare SfxJpegWriter with machines where this code works. You may also want

to copy this dll from one of the "good" machines and reregister using

regsvr32.

I also remember a problem where certain security settings in a machine would

make a dll with more than 8 characters not to be loaded in Windows. If

copying the dll from another licensed machine doesn't fix this issue you may

want to try renaming this dll (any name with less than 8 characters will

do).

You should reset IIS before any of these actions to make sure the ChartFX

dlls are not in use.

--

Regards,

JC

Software FX Support

"Thomas Ziomek" <tomz@zwebgraphics.com> wrote in message

news:UUkZ6NpgDHA.3600@WEBSERVER1...

> I have the same code deployed to numerous servers. On only one of the

> machines, we get the following error output to the browser:

>

> An Exception Occurred: 'GetHtmlTag'

>

> The line of code that blows up is in the ASP page as follows:

>

> strChartTag = objChart.GetHtmlTag(600,400,"Jpeg")

>

> Pls note that in this ASP page, this is the second call to GetHtmlTag.

The

> earlier call is the standard <%= objChart.GetHtmlTag("100%","100%") %>

>

> As I said, this code works on a bunch of machines. This is the only one

> that doesn't work. It is the newest of our installs.

>

> Thanks!

>

>

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...