Jump to content
Software FX Community

Failed to download license


User (Legacy)
 Share

Recommended Posts

I recently installed ChartFXIE 5.5 on Server 2003. I manually created all

the virtual directories the support site said to create (License, Download,

Include and CfxTemp) and gave the IUser_Machine account the suggested

permissions. When I try loading the page, though I get the Failed to

download license error message. The lic file does exist, the License virtual

directory is there and the user has permissons on the real directory. Any

ideas where to go from here? Thanks.

Clint Stearns

Link to comment
Share on other sites

Have you tried typing the license URL in a new browser ?

Are you testing this with a server-side sample (ASP page) or a Client-side

sample (HTML page that includes the OBJECT tag to create a chart) ?

--

Regards,

JC

Software FX Support

"Clint Steans" <clint@uiuc.edu> wrote in message

news:co%23LQxwHDHA.2972@webserver1.softwarefx.com...

> I recently installed ChartFXIE 5.5 on Server 2003. I manually created all

> the virtual directories the support site said to create (License,

Download,

> Include and CfxTemp) and gave the IUser_Machine account the suggested

> permissions. When I try loading the page, though I get the Failed to

> download license error message. The lic file does exist, the License

virtual

> directory is there and the user has permissons on the real directory. Any

> ideas where to go from here? Thanks.

>

> Clint Stearns

>

>

Link to comment
Share on other sites

What OS are you running on your server ? Is it Windows Server 2003 ?

--

Regards,

JC

Software FX Support

"Clint Steans" <clint@uiuc.edu> wrote in message

news:f7QutOxHDHA.3516@webserver1.softwarefx.com...

> I have tried typing in the URL in my browser. What I get is a 404 not

found

> error. Funny thing is, if I enable browsing on my license directory the

file

> shows in the list. Clicking on it though gets a 404 not found.

>

> "SoftwareFX Support" <support@softwarefx.com> wrote in message

> news:9t99u8wHDHA.2132@webserver1.softwarefx.com...

> > Have you tried typing the license URL in a new browser ?

> >

> > Are you testing this with a server-side sample (ASP page) or a

Client-side

> > sample (HTML page that includes the OBJECT tag to create a chart) ?

> >

> > --

> > Regards,

> >

> > JC

> > Software FX Support

> > "Clint Steans" <clint@uiuc.edu> wrote in message

> > news:co%23LQxwHDHA.2972@webserver1.softwarefx.com...

> > > I recently installed ChartFXIE 5.5 on Server 2003. I manually created

> all

> > > the virtual directories the support site said to create (License,

> > Download,

> > > Include and CfxTemp) and gave the IUser_Machine account the suggested

> > > permissions. When I try loading the page, though I get the Failed to

> > > download license error message. The lic file does exist, the License

> > virtual

> > > directory is there and the user has permissons on the real directory.

> Any

> > > ideas where to go from here? Thanks.

> > >

> > > Clint Stearns

> > >

> > >

> >

> >

>

>

Link to comment
Share on other sites

I have tried typing in the URL in my browser. What I get is a 404 not found

error. Funny thing is, if I enable browsing on my license directory the file

shows in the list. Clicking on it though gets a 404 not found.

"SoftwareFX Support" <support@softwarefx.com> wrote in message

news:9t99u8wHDHA.2132@webserver1.softwarefx.com...

> Have you tried typing the license URL in a new browser ?

>

> Are you testing this with a server-side sample (ASP page) or a Client-side

> sample (HTML page that includes the OBJECT tag to create a chart) ?

>

> --

> Regards,

>

> JC

> Software FX Support

> "Clint Steans" <clint@uiuc.edu> wrote in message

> news:co%23LQxwHDHA.2972@webserver1.softwarefx.com...

> > I recently installed ChartFXIE 5.5 on Server 2003. I manually created

all

> > the virtual directories the support site said to create (License,

> Download,

> > Include and CfxTemp) and gave the IUser_Machine account the suggested

> > permissions. When I try loading the page, though I get the Failed to

> > download license error message. The lic file does exist, the License

> virtual

> > directory is there and the user has permissons on the real directory.

Any

> > ideas where to go from here? Thanks.

> >

> > Clint Stearns

> >

> >

>

>

Link to comment
Share on other sites

Yes. Server 2003.

"SoftwareFX Support" <support@softwarefx.com> wrote in message

news:QYsYKSxHDHA.3316@webserver1.softwarefx.com...

> What OS are you running on your server ? Is it Windows Server 2003 ?

>

> --

> Regards,

>

> JC

> Software FX Support

> "Clint Steans" <clint@uiuc.edu> wrote in message

> news:f7QutOxHDHA.3516@webserver1.softwarefx.com...

> > I have tried typing in the URL in my browser. What I get is a 404 not

> found

> > error. Funny thing is, if I enable browsing on my license directory the

> file

> > shows in the list. Clicking on it though gets a 404 not found.

> >

> > "SoftwareFX Support" <support@softwarefx.com> wrote in message

> > news:9t99u8wHDHA.2132@webserver1.softwarefx.com...

> > > Have you tried typing the license URL in a new browser ?

> > >

> > > Are you testing this with a server-side sample (ASP page) or a

> Client-side

> > > sample (HTML page that includes the OBJECT tag to create a chart) ?

> > >

> > > --

> > > Regards,

> > >

> > > JC

> > > Software FX Support

> > > "Clint Steans" <clint@uiuc.edu> wrote in message

> > > news:co%23LQxwHDHA.2972@webserver1.softwarefx.com...

> > > > I recently installed ChartFXIE 5.5 on Server 2003. I manually

created

> > all

> > > > the virtual directories the support site said to create (License,

> > > Download,

> > > > Include and CfxTemp) and gave the IUser_Machine account the

suggested

> > > > permissions. When I try loading the page, though I get the Failed to

> > > > download license error message. The lic file does exist, the License

> > > virtual

> > > > directory is there and the user has permissons on the real

directory.

> > Any

> > > > ideas where to go from here? Thanks.

> > > >

> > > > Clint Stearns

> > > >

> > > >

> > >

> > >

> >

> >

>

>

Link to comment
Share on other sites

Windows Server 2003 is installed in a "secure by default" mode which means

IIS 6.0 will not serve (return) any files that it does not recognize (using

the file extension and the mime types).

You will have to add lic (and probably chw) to the list of mime types in the

IIS Service Manager.

Steps

- Internet Information Service Manager

- Right click "Default Web Site" and select properties

- HTTP Headers page

- Click on the "MIME Types" button

- Click new

- Set the extension to chw and the mime type to "application/octet-stream"

- Click new

- Set the extension to lic and the mime type to "application/octet-stream"

- OK ...

--

Regards,

JC

Software FX Support

"Clint Steans" <clint@uiuc.edu> wrote in message

news:F%23db7CHIDHA.2972@webserver1.softwarefx.com...

> Yes. Server 2003.

>

> "SoftwareFX Support" <support@softwarefx.com> wrote in message

> news:QYsYKSxHDHA.3316@webserver1.softwarefx.com...

> > What OS are you running on your server ? Is it Windows Server 2003 ?

> >

> > --

> > Regards,

> >

> > JC

> > Software FX Support

> > "Clint Steans" <clint@uiuc.edu> wrote in message

> > news:f7QutOxHDHA.3516@webserver1.softwarefx.com...

> > > I have tried typing in the URL in my browser. What I get is a 404 not

> > found

> > > error. Funny thing is, if I enable browsing on my license directory

the

> > file

> > > shows in the list. Clicking on it though gets a 404 not found.

> > >

> > > "SoftwareFX Support" <support@softwarefx.com> wrote in message

> > > news:9t99u8wHDHA.2132@webserver1.softwarefx.com...

> > > > Have you tried typing the license URL in a new browser ?

> > > >

> > > > Are you testing this with a server-side sample (ASP page) or a

> > Client-side

> > > > sample (HTML page that includes the OBJECT tag to create a chart) ?

> > > >

> > > > --

> > > > Regards,

> > > >

> > > > JC

> > > > Software FX Support

> > > > "Clint Steans" <clint@uiuc.edu> wrote in message

> > > > news:co%23LQxwHDHA.2972@webserver1.softwarefx.com...

> > > > > I recently installed ChartFXIE 5.5 on Server 2003. I manually

> created

> > > all

> > > > > the virtual directories the support site said to create (License,

> > > > Download,

> > > > > Include and CfxTemp) and gave the IUser_Machine account the

> suggested

> > > > > permissions. When I try loading the page, though I get the Failed

to

> > > > > download license error message. The lic file does exist, the

License

> > > > virtual

> > > > > directory is there and the user has permissons on the real

> directory.

> > > Any

> > > > > ideas where to go from here? Thanks.

> > > > >

> > > > > Clint Stearns

> > > > >

> > > > >

> > > >

> > > >

> > >

> > >

> >

> >

>

>

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...