Jump to content
Software FX Community

Re: legends


User (Legacy)

Recommended Posts

Legends work consistently when I use "Image" in the GetHtmlTag 

function. However, I would like to be able to use the Active X.

Any suggestions?

Juan Cegarra wrote in message ...

>Can you check the version of the "ChartFX IE 4.0 Control" in your

>"\WinNT\Downloaded Program Files" folder.

>

>I created a page with your code (using a Resultset with two numerical

>fields) and the legend box appears as expected.

>

>Regards,

>

>Juan Cegarra

>Software FX, Inc.

>juanc@softwarefx.com

>

>

>-----Original Message-----

>From: CfxIE4B On Behalf Of Margaret Barrett

>Posted At: Monday, August 16, 1999 9:12 AM

>Posted To: Server

>Conversation: legends

>Subject: legends

>

>

>Here is the code that generates my graph. I cannot get the legend box

>to

>display consistently. Any suggestions? It seems to be there with size

>= 0

>because when I look at it in browser and click legend box , something

>small

>disappears and if I click again it appears the right size. Help?????

>

>Set conn2 = Server.CreateObject("ADODB.Connection")

>

>conn2.Open("DBQ=D:\Database\SupplyEff\SuppEff.mdb;DefaultDir=D:\Database

>\Sup

>plyEff;Driver={Microsoft Access Driver (*.mdb)};DriverId=25;FIL=MS

>Access;ImplicitCommitSync=Yes;MaxBufferSize=512;MaxScanRows=8;PageTimeou

>t=5;

>SafeTransactions=0;Threads=3;UID=admin;UserCommitSync=Yes;")

> set rs = conn2.Execute(chartsqlA)

> set Chart2 = Server.CreateObject("ChartFX.WebServer4B")

> Chart2.AdoResultset(rs)

> Chart2.Chart3D = False

> Chart2.Type = Chart2.Type or CT_SHOWVALUES or CT_SERLEGEND

> Chart2.SerLegBox = True

> Chart2.OpenDataEx 65, 2, J

> Chart2.CloseData 65

> Chart2.OpenDataEx COD_COLORS,2,1

> Chart2.color(0)=RGB(0,255,0)

> Chart2.series(1).color=RGB(0,0,255)

> Chart2.CloseData COD_COLORS

> Chart2.Series(0).Gallery =4

> Chart2.Series(1).Gallery =2

> Chart2.Series(0).MarkerShape = 2

> Chart2.Series(0).MarkerSize = 5

> Chart2.series(0).legend = "Effectiveness"

> Chart2.series(1).legend= "Total Demand"

> Chart2.Axis(AXIS_Y).Step = 10

> Chart2.Axis(AXIS_Y).Min = 70

> Chart2.Axis(AXIS_Y).Max = 100

> Chart2.Title(2) = "Effectiveness"

> Chart2.Series(1).YAxis = AXIS_Y2

> Chart2.Axis(AXIS_Y).Format = "#,##0"

> Chart2.Axis(AXIS_Y2).Format = "#,##0"

> Chart2.Axis(AXIS_Y2).Step = 500

> Chart2.Axis(AXIS_Y2).Min = 0

> Chart2.Axis(AXIS_Y2).Max = 2000

> Chart2.series(1).PointLabels = 1

> Chart2.series(0).PointLabels = 1

> Chart2.OpenDataEx 2, 1, 0

> Chart2.Const(0) = 95

> Chart2.FixLeg(0) = "Goal"

> Chart2.ConstantLine(0).LineStyle = 1

> Chart2.ConstantLine(0).LineColor = RGB(255,0,0)

> Chart2.CloseData 2

>

Link to comment
Share on other sites

Legends work consistently when I use "Image" in the GetHtmlTag 

function. However, I would like to be able to use the Active X.

Any suggestions?

Juan Cegarra wrote in message ...

>Can you check the version of the "ChartFX IE 4.0 Control" in your

>"\WinNT\Downloaded Program Files" folder.

>

>I created a page with your code (using a Resultset with two numerical

>fields) and the legend box appears as expected.

>

>Regards,

>

>Juan Cegarra

>Software FX, Inc.

>juanc@softwarefx.com

>

>

>-----Original Message-----

>From: CfxIE4B On Behalf Of Margaret Barrett

>Posted At: Monday, August 16, 1999 9:12 AM

>Posted To: Server

>Conversation: legends

>Subject: legends

>

>

>Here is the code that generates my graph. I cannot get the legend box

>to

>display consistently. Any suggestions? It seems to be there with size

>= 0

>because when I look at it in browser and click legend box , something

>small

>disappears and if I click again it appears the right size. Help?????

>

>Set conn2 = Server.CreateObject("ADODB.Connection")

>

>conn2.Open("DBQ=D:\Database\SupplyEff\SuppEff.mdb;DefaultDir=D:\Database

>\Sup

>plyEff;Driver={Microsoft Access Driver (*.mdb)};DriverId=25;FIL=MS

>Access;ImplicitCommitSync=Yes;MaxBufferSize=512;MaxScanRows=8;PageTimeou

>t=5;

>SafeTransactions=0;Threads=3;UID=admin;UserCommitSync=Yes;")

> set rs = conn2.Execute(chartsqlA)

> set Chart2 = Server.CreateObject("ChartFX.WebServer4B")

> Chart2.AdoResultset(rs)

> Chart2.Chart3D = False

> Chart2.Type = Chart2.Type or CT_SHOWVALUES or CT_SERLEGEND

> Chart2.SerLegBox = True

> Chart2.OpenDataEx 65, 2, J

> Chart2.CloseData 65

> Chart2.OpenDataEx COD_COLORS,2,1

> Chart2.color(0)=RGB(0,255,0)

> Chart2.series(1).color=RGB(0,0,255)

> Chart2.CloseData COD_COLORS

> Chart2.Series(0).Gallery =4

> Chart2.Series(1).Gallery =2

> Chart2.Series(0).MarkerShape = 2

> Chart2.Series(0).MarkerSize = 5

> Chart2.series(0).legend = "Effectiveness"

> Chart2.series(1).legend= "Total Demand"

> Chart2.Axis(AXIS_Y).Step = 10

> Chart2.Axis(AXIS_Y).Min = 70

> Chart2.Axis(AXIS_Y).Max = 100

> Chart2.Title(2) = "Effectiveness"

> Chart2.Series(1).YAxis = AXIS_Y2

> Chart2.Axis(AXIS_Y).Format = "#,##0"

> Chart2.Axis(AXIS_Y2).Format = "#,##0"

> Chart2.Axis(AXIS_Y2).Step = 500

> Chart2.Axis(AXIS_Y2).Min = 0

> Chart2.Axis(AXIS_Y2).Max = 2000

> Chart2.series(1).PointLabels = 1

> Chart2.series(0).PointLabels = 1

> Chart2.OpenDataEx 2, 1, 0

> Chart2.Const(0) = 95

> Chart2.FixLeg(0) = "Goal"

> Chart2.ConstantLine(0).LineStyle = 1

> Chart2.ConstantLine(0).LineColor = RGB(255,0,0)

> Chart2.CloseData 2

>

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...