Jump to content
Software FX Community

.4 scaling step for {1,2,3}


Recommended Posts

If I send a series {4,5,6} to the chart, the autoscale uses a step of 1.

If I send a series {1,2,3} to the chart, the autoscale uses a step of .4.

If I send both series, I get an auto step of 1.

Of course, I like the step of 1 that is calculated, and I further remove the

Y label decimals when this occurs. Looks good.

Is this .4 step a bug that has been fixed (I'm using trial 6.2.1342.0)? Or

is there some other setting I could make so that the autoscaling tends more

toward integers?

Thanks,

Greg

Link to post
Share on other sites

The Step is chosen base on the Min and Max, the space available and the axis 

formatting. The Min and Max are changing as you pass one series, another or

both and therefore the Step calculation is being affected.

If you start by setting the Y-Axis number of decimals to zero (prior to

setting your data), we will always chose a step that has no decimals (your

Min and Max must be integers as well or they will be rounded after data is

passed).

You can also fix the step by assigning:

chart.AxisY.Step = 1;

--

FP

Software FX

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...