Jump to content
Software FX Community

Can't add chart to any form


Recommended Posts

More info:  I noticed that the ChartFX assembly version is 6.0.839.  That is

old. I upgraded to a newer version a long time ago. So I went to the

update site and the updater says "Error" in the Version column for all

components.

What's wrong and how do I fix it? Should I just uninstall/reinstall?

Link to post
Share on other sites

Ignore the info about the version numbers, I was looking at the 6.2 upgrade

site, not the 6.0 site.

Anyway, this still isn't working. I have reinstalled both ChartFX and

Visual Studio.NET 2003 to no avail. When I drag the chart from the toolbox

nothing happens. No error or anything.

I need to get this working. I saw a similar post from someone else with the

same problem but no answer was ever posted.

Link to post
Share on other sites

I have seen this problem and it almost always is a configuration issue.

I can only give you hints as to what to try and even after the issue is

solved I cannot pinpoint the reason.

1) Have you tried creating a new project?

2) If you are using an existing webform , when you do view code do you see a

Chart object already there left over from a previous crash. That sometimes

happens? Check the Member Objects that are private or protected.

3) Verify that you have no older versions of ChartFX mixing in with the new

version. Check your Reference Paths in the Project Properties.

4) Please check the Version number in the Right Click in ToolBox -> Add

Remove Items -> .Net Framework Components-> Assembly Name ListBox

5) Finally, Try deleting the ChartFX Icon from the ToolBox, closing Visual

Studio, creating new project Adding ChartFX manually back to the tool bar.

That might resolve the Issue. Try Winforms first!

In short these problems are very rare and are almost always related to a

configuration problem. I create new versions of ChartFX every day as I

compile and only rarely do I have this problem. I have seen it though and

have no reason to suspect it is a ChartFX issue/bug and in every case I saw

it was my own error/mistake that caused the problem.

Hope this helps.

-CharlesS

"None" <none@nowhere.com> wrote in message

news:obaYvY%23NEHA.3152@webserver3.softwarefx.com...

> Ignore the info about the version numbers, I was looking at the 6.2

upgrade

> site, not the 6.0 site.

>

> Anyway, this still isn't working. I have reinstalled both ChartFX and

> Visual Studio.NET 2003 to no avail. When I drag the chart from the

toolbox

> nothing happens. No error or anything.

>

> I need to get this working. I saw a similar post from someone else with

the

> same problem but no answer was ever posted.

>

>

Link to post
Share on other sites

I've already tried all of your suggestions.  When I drag a chart to a

WinForm then three references are added (chartfx, ChartFX.Base,

ChartFX.Borders) to the project but no chart appears on the form. Reference

Paths is empty (that should be ok).

Shouldn't a license.licx file be created? There is no file.

I tried a WebForm but it will not let me drag the chart to the form.

"Software FX Support" <support@softwarefx.com> wrote in message

news:JG86r$COEHA.3152@webserver3.softwarefx.com...

> I have seen this problem and it almost always is a configuration issue.

> I can only give you hints as to what to try and even after the issue is

> solved I cannot pinpoint the reason.

> 1) Have you tried creating a new project?

> 2) If you are using an existing webform , when you do view code do you see

a

> Chart object already there left over from a previous crash. That sometimes

> happens? Check the Member Objects that are private or protected.

> 3) Verify that you have no older versions of ChartFX mixing in with the

new

> version. Check your Reference Paths in the Project Properties.

> 4) Please check the Version number in the Right Click in ToolBox -> Add

> Remove Items -> .Net Framework Components-> Assembly Name ListBox

> 5) Finally, Try deleting the ChartFX Icon from the ToolBox, closing Visual

> Studio, creating new project Adding ChartFX manually back to the tool bar.

> That might resolve the Issue. Try Winforms first!

>

> In short these problems are very rare and are almost always related to a

> configuration problem. I create new versions of ChartFX every day as I

> compile and only rarely do I have this problem. I have seen it though and

> have no reason to suspect it is a ChartFX issue/bug and in every case I

saw

> it was my own error/mistake that caused the problem.

>

> Hope this helps.

>

> -CharlesS

>

> "None" <none@nowhere.com> wrote in message

> news:obaYvY%23NEHA.3152@webserver3.softwarefx.com...

> > Ignore the info about the version numbers, I was looking at the 6.2

> upgrade

> > site, not the 6.0 site.

> >

> > Anyway, this still isn't working. I have reinstalled both ChartFX and

> > Visual Studio.NET 2003 to no avail. When I drag the chart from the

> toolbox

> > nothing happens. No error or anything.

> >

> > I need to get this working. I saw a similar post from someone else with

> the

> > same problem but no answer was ever posted.

> >

> >

>

>

Link to post
Share on other sites

Just to be clear, I don't have 6.2 at all, just 6.0.

"Software FX Support" <support@softwarefx.com> wrote in message

news:72vfE7DOEHA.3080@webserver3.softwarefx.com...

> Chart FX 6.0 and 6.2 can live side-by-side so upgrading to 6.2 will not

> remove 6.0.

>

> Go to your project settings and set the reference path to be that of Chart

> FX 6.2.

>

> When you check the version of the assemblies in your references they all

> should read 6.2.*.

>

> In particular, you seem to be having a problem with one of the design time

> DLL, looks like while Chart FX 6.2 is being loaded in your project, the

6.0

> designer is loaded by VS. Fixing the reference path and re-opening your

> project should fix that problem.

>

> --

> FP

> Software FX Support

>

>

Link to post
Share on other sites

Chart FX 6.0 and 6.2 can live side-by-side so upgrading to 6.2 will not

remove 6.0.

Go to your project settings and set the reference path to be that of Chart

FX 6.2.

When you check the version of the assemblies in your references they all

should read 6.2.*.

In particular, you seem to be having a problem with one of the design time

DLL, looks like while Chart FX 6.2 is being loaded in your project, the 6.0

designer is loaded by VS. Fixing the reference path and re-opening your

project should fix that problem.

--

FP

Software FX Support

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...