Jump to content
Software FX Community


Recommended Posts

 So I rebooted my server I run the power gadgets on and now any gadgets I try and display it gives me an error.

 Example error:

out-gauge : Cannot process argument because the value of argument "runspaceConfiguration" in null.  Change the value of argument "runspaceConfiguration" to a non-null value.

Link to comment
Share on other sites

  • 3 months later...

 Just a not to everyone... This is not limited to an "older version" of Powergadgets I had the same issue with the lastest version running.  It appears to be an issue with PowerShell 3.0 and powergadgets in general.  Furthermore, it doesn't occur on *all* of my scripts that use out-gauge.  I was not able to pinpoint a specific difference between the places where it worked and where it didn't, however uninstalling powershell 3.0 fixes the issue.

 This proved to be a real issue for me as I needed powershell 3.0 for another script that I'm running on the box.  Today however I was able to successfully work around this issue with Powershell 3.0 installed.

I re-installed Powershell 3.0 on my machine and confirmed that the same scripts with out-gauge that were previously crashing were still doing so.

I then modified my scheduled tasks that were actually calling the powershell scripts in question to start powershell with the -version 2.0 flag.  When starting powershell with this commandline option before launching my scripts that were crashing in powershell 3.0 everything works fine.

 So if you need powershell 3.0 on the box and also need out-gauge to work, be aware that as long as you aren't needing powershell 3.0 specific features in the scripts that call out-gauge, you can use this workaround to allow things to work.

Link to comment
Share on other sites

Can you please send us one of the powershell scripts that worked when you uninstalled powershell 3.0 and stopped working after reinstalling powershell 3.0?

You can send it to support at softwarefx dot com, if it has proprietary information in you can send us an edited version with the out-gauge parameters only as I do not think it depends on the data. It is probably a bug related to one of the parameters or powergadgets template you are using.


Link to comment
Share on other sites

 I should also state that when testing a couple of scripts before emailing this, I seem to have found a common denominator.  At least for several of the scripts that were crashing they are ones that had "drill_through" scripts specified. As several of them after removing this parameter they run fine.  Though I do have other scripts that are also using that and work just fine, so still not 100% certain what the combination is.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...