Jump to content
Software FX Community
Sign in to follow this  
DJake

Apparent Bug in Single x-value out-charts when Refreshing

Recommended Posts

Hi Gang,

It appears to me that there is some bug or intended function that is undesirable in many situations involving the out-chart with refresh.  If you create an out-chart .PS1 gadget that is attached to dynamic data and the first rendering of the gadget results in a single x-axis value (point, column, etc) then subsequent automatic or manual refreshes will not update the single value on the chart, but rather introduce a timescale for the x-axis and add additional copies of the same data point at different refresh intervals.  I understand there is an option that can remove this behavior, but I haven't found it in the documentation.  I have included a couple of visual examples below, which I hope will be more illustrative. 

I want the gadget chart to retain a single x-axis entry and update it's y-axis value, not replicate the single value over time.  Note: once more than one x-axis value appears, the problem goes away.  Note#2: if you originally open the gadget with more than one x-axis value in the data, but the data refresh subsequently reduces to a single x-axis value (datapoint) then the behavior does not occur.  I can post the invoke-sql | out-chart code if that will help.  Thanks a bunch for the help!

Best,

David

 http://www.zweenahealth.com/JNA/Download/PGexample1.bmp

http://www.zweenahealth.com/JNA/Download/PGexample2.bmp

 

Share this post


Link to post
Share on other sites

To disable this behavior please add -DisableAuto AddData to your out chart cmdlet invocation, e.g.

C:> get-date -uformat "%S" | out-chart -refresh 0:0:1 -DisableAuto AddData

Note that support for this flag was added in build 2769

JuanC

Share this post


Link to post
Share on other sites

Thanks, Juan

I'm pretty certain I'm current--downloaded the latest versions last month.  I will give it a try and let you know in the am (that's when most of my charts are sparse).  Best,

David

Share this post


Link to post
Share on other sites

Good morning, Juan

I gave it a try this morning and received the error below.  I am running version Version: 1.0.2760.16652, which is the latest build available that I can find on the PG web-site.  "2760" looks strangely close but lower than "2769."  Are these two numbers related?  Do I have the 2769 build, and if not, how do I obtain it?  Does the error below give you an indication that the problem is something other than the build I am running?

On a related, silly question note, will DisableAuto AddData (when functioning properly) keep a chart from adding new, valid datapoints on refresh as they evolve when the invoke-sql picks up a query with more than the 1 originial datapoint?

Thank you very much for your help.  Best, David

Posted Image

Share this post


Link to post
Share on other sites

Yes, you will need to upgrade.  Email support@online.powergadgets.com (remove "online.") to get the latest download location.

As for you -disableauto parameter question, everytime the chart refreshes, things will basically start from scratch: if there's one data point, the graph will only show one, if there's more than one, the graph will show 2 data points.  Is that the behaviour you're looking for?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...