Jump to content
Software FX Community
filler

Chart not appearing in deployed report

Recommended Posts

Hi, I just downloaded the trial version of ChartFX for Reporting Services.  I am working with a Report Project in VS2005 and used the ChartFX control.  I created a chart fine, it is doing what I need it to, and within the VS2005 designer, I can click on the

Share this post


Link to post
Share on other sites

 Same issue here. I have the demo product installed on my development server and have deployed while connected to the server using RDP. When I veiw my report through SharePoint, the charts are not showing.

This is critical for me as I have to show a POC to my team on Monday as a final decision will be made then as to which vendor we will be using.

Any response would be appreciated!

C

Share this post


Link to post
Share on other sites

Was there any resolution or recommendation for this issue?  I am also evaluating ChartFX using VS 2005 and SQL Reporting services.  Deployed report does not show the chart (whereas preview in the designer does).  Any help would be appreciated on this as I am getting ready to purchase this product and deploy for my client...

 Thanks,

 Phil J

Share this post


Link to post
Share on other sites

 Verify that Chart FX libraries were copied to the right folders using the following steps: a) Go to C:\Program Files\Microsoft SQL Server\MSSQL.3\Reporting Services\ReportServer\bin (It could be MSSQL.2, MSSQL.4, etc). The .dlls you need here are: ChartFX.ReportingServices.Adornments.dll ChartFX.ReportingServices.Base.dll ChartFX.ReportingServices.dll ChartFX.ReportingServices.Gauge.dll ;) Go to C:\Program Files\Microsoft Visual Studio 8\Common7\IDE\PrivateAssemblies. The .dlls and corresponding .xmls that you need here are: ChartFX.ReportingServices.Adornments.dll ChartFX.ReportingServices.Base.dll ChartFX.ReportingServices.Designer.xml ChartFX.ReportingServices.Designer.dll ChartFX.ReportingServices.dll ChartFX.ReportingServices.Gauge.Designer.xml ChartFX.ReportingServices.Gauge.Designer.dll ChartFX.ReportingServices.Gauge.dll If the previously mentioned files are not located in those folders, please copy them from the bin folder of your Chart FX Reporting Services installation. After verifying that these files are located in their correct folders, do the following: Open C:\Program Files\Microsoft SQL Server\MSSQL.3\Reporting Services\ReportServer\rssrvpolicy with a text editor (notepad) and add the following entry: <CodeGroup class="UnionCodeGroup" version="1" PermissionSetName="FullTrust" Name="SoftwareFX_Strong_Name" Description="This code group grants Chart FX Reporting Services FUllTrust permission."> <IMembershipCondition class="StrongNameMembershipCondition" version="1" PublicKeyBlob="00240000048000009400000006020000002400005253413100040000010001003D35B05AC523A5DBBDB65B6158A5DE0EB20D2519FF6956AE294FCADA2CA2D354428A1163F56E8294C277132BA0759D85B87DF88169B63F8519882738BBA48B91260F3E090252DE6DA366E8F16EE32B4C816CD9F6A466232D57E55BB92CAE3E4A6E01B4C0B41241819D25D5DCBF6F1CDDB0B7ABBAE608CB541106E8855F0BCEB6"/> </CodeGroup> Also, please open C:\Program Files\Microsoft SQL Server\MSSQL.3\Reporting Services\ReportServer\rsreportserver and add the following entry: <ReportItems> <ReportItem Name="Chart" Type="ChartFX.ReportingServices.Chart,ChartFX.ReportingServices"/> <ReportItem Name="RadialGauge" Type="ChartFX.ReportingServices.Gauge.RadialGauge,ChartFX.ReportingServices.Gauge"/> <ReportItem Name="VerticalGauge" Type="ChartFX.ReportingServices.Gauge.VerticalGauge,ChartFX.ReportingServices.Gauge"/> <ReportItem Name="HorizontalGauge" Type="ChartFX.ReportingServices.Gauge.HorizontalGauge,ChartFX.ReportingServices.Gauge"/> <ReportItem Name="DigitalPanel" Type="ChartFX.ReportingServices.Gauge.DigitalPanel,ChartFX.ReportingServices.Gauge"/> </ReportItems> I am attaching two files from my own installation. Use them as reference when editing your own files.

post-2982-13922406471491_thumb.gif

Share this post


Link to post
Share on other sites

Andre,

 Thank you for the reply.  I have tried the solution you recommended, but still no luck.  The files were in the appropriate folders, but the 2 config files were missing the sections you highlighted.  After adding them and rebooting, I was hopeful that this would work.  Instead, there was no change - chart still does not appear in the report when viewed in the browser....

As this is a test machine, I am tempted to clean install everything and see if that clears everything up - but thatwould take significant time with no guarantee of success.....

Anything else to try that you can think of?

 Thanks,

Phil

Share this post


Link to post
Share on other sites

Just a follow-up... I set up a second machine with all software (clean install of Windows 2003 server, SQL Express 2005, SQL Reporting services, VS BITS etc.) and I have the exact same problem.  I noted that the config entries that you sent me were not in my config files after install of ChartFX software.  I put them in and still no go.

 I did some research on the PublicKeyBlob method you use to allow Chart FX permission to run in the context of a report and I used the sn.exe tool to attempt to verify that the key that the config line was trying to register was actually installed properly on the machine (sn.exe -e "SoftwareFX_Strong_Name" -Tp).  This utility returned an error that it could not find the name registered on my computer.

 Don't know if any of this will lead us in another direction, but I am still stuck with no solution for my client....

Thanks again,

Phil

Share this post


Link to post
Share on other sites

I did finally resolve this issue and wanted to post a note as to what the problem was...

It turned out to be a setup issue on my test machine.  I was using SQL Express 2005 with Reporting services rather than a full version of SQL 2005.  It seems that there are a few "behind the scenes" things that Microsoft disabled in SQL Express that cause OCX controls to not appear in the published report even though they appear just fine in preview mode...

 Once I upgraded to SQL 2005 Standard, everything displayed properly....

- Phil

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...