Jump to content
Software FX Community
Sign in to follow this  
User (Legacy)

Problems with designer

Recommended Posts

Using ChartFX for Winforms for approx 2 months.

Downloaded and installed latest update and immediately am having issues with

the designer.

Same problem occurs with any of your samples or a new project/default chart.

I cannot change the chart gallery within the designer and attempting to do

so causes of other issues, thereafter.

Load any sample or create new chart:

Click on smart tag, 'Select chart gallery'

Make any selection - dialog immediately closes, not change was made.

If I then select 'Adjust Data to chart' it shows the 'chart gallery' dialog.

(see attached image).

All of the samples and my existing projects run correctly with the new

version, its only the designer that seems to be having issues.

Please advise how I can resolve this.

Share this post


Link to post
Share on other sites

Another issue Im having with the designer is I can no longer create a 

Cross-tab report.

I have several I have created prior to applying the update, but now when I

select 'Adjust Data to Chart' and select the columns for the series- I get

an error that more than one non-numeric field has been found vs the prompt

to create a crosstab that I received with the prior version.

post-2107-13922364373602_thumb.jpg

Share this post


Link to post
Share on other sites
Software FX    0

This sounds like a version problem.

Please do the following:

1) Go to the Chart FX installation folder and delete all DLLs from the

Wizard Folder

2) Make sure you replace the Chart FX dlls in your application's Bin

directory with those in Chart FX's Bin folder

3) Make sure all File Versions in Chart FX's Bin folder have the same

version number, only the revision number (last of four numbers) should be

different.

--

Francisco Padron

www.chartfx.com

Share this post


Link to post
Share on other sites

I have uninstalled/reinstalled/repatched several times trying to resolve 

this (results always same)

The first version installed was 7.0.2330

Update was to 7.0.2540

If I uninstall and then reinstall .2330, the issue with the wizard does not

occur.

Install the patch to .2540 and it returns.

I followed your instructions below, verifying that all DLLs show .2540 and

deleted the DLLs in the \Wizard folder, and copied over the dlls in the apps

bin\debug folder.

With the Wizard DLL´s deleted, Im getting an ´Object reference not set to an

instance of an object´ error when I try to access the design wizards from

the smart tag menu. Re-ran update, same result.

How are the wizard DLL´s created/replaced? I´m assuming their deletion is

the cause of the object ref error.

Regards,

Tim

"Software FX" <noreply@softwarefx.com> wrote in message

news:HEnECG7THHA.3588@webserver3.softwarefx.com...

> This sounds like a version problem.

>

> Please do the following:

>

> 1) Go to the Chart FX installation folder and delete all DLLs from the

> Wizard Folder

> 2) Make sure you replace the Chart FX dlls in your application´s Bin

> directory with those in Chart FX´s Bin folder

> 3) Make sure all File Versions in Chart FX´s Bin folder have the same

> version number, only the revision number (last of four numbers) should be

> different.

> --

> Francisco Padron

> www.chartfx.com

Share this post


Link to post
Share on other sites
Software FX    0

The Wizard Dlls are created on the fly when needed. When you invoke the 

Gallery wizard, do the dll's get created?

We are unable to reproduce the problem you are describing with a correct

setup, however, if we mix-up dll versions we get the error you are getting.

Did you ever added Chart FX dlls to the Global Assembly Cache (GAC) ? Look

everywhere in your disk for Chart FX dlls and ensure they are all the newer

version.

--

Francisco Padron

www.chartfx.com

Share this post


Link to post
Share on other sites

The wizard DLLs are not being created after manual deletion.

I have only used the installation program to install/update.

When uninstalling, several files and the base folder structure are left

behind and I manually delete those but have not checked the GAC after an

uninstall. Is it possible to get an install with just the latest files

so I would not need to apply the patch? I purchased through

ComponentSource and re-downloaded from their FTP site but it was the

same version.

"Software FX" <noreply@softwarefx.com> wrote in message

news:%23$2XUlIUHHA.1212@webserver3.softwarefx.com...

> The Wizard Dlls are created on the fly when needed. When you invoke the

> Gallery wizard, do the dll´s get created?

>

> We are unable to reproduce the problem you are describing with a correct

> setup, however, if we mix-up dll versions we get the error you are

> getting. Did you ever added Chart FX dlls to the Global Assembly Cache

> (GAC) ? Look everywhere in your disk for Chart FX dlls and ensure they are

> all the newer version.

>

> --

> Francisco Padron

> www.chartfx.com

Share this post


Link to post
Share on other sites
Software FX    0

I don't think getting a new installer will work but yes, you can get one by 

calling or e-mailing software fx support.

Both the installer and the Service Pack will only replace the file in the

Chart FX folders where they were installed, copies made by you or by Visual

Studio will remain as they are.

We do NOT install any files in the GAC but if you did this manually, they

will take precedence over anything installed in your disk.

--

Francisco Padron

www.chartfx.com

Share this post


Link to post
Share on other sites

So..if you do not think a new installation of current version will resolve 

the issue, what do you suggest?

"Software FX" <noreply@softwarefx.com> wrote in message

news:gpH5Y6QUHHA.1212@webserver3.softwarefx.com...

>I don´t think getting a new installer will work but yes, you can get one by

>calling or e-mailing software fx support.

>

> Both the installer and the Service Pack will only replace the file in the

> Chart FX folders where they were installed, copies made by you or by

> Visual Studio will remain as they are.

>

> We do NOT install any files in the GAC but if you did this manually, they

> will take precedence over anything installed in your disk.

>

> --

> Francisco Padron

> www.chartfx.com

Share this post


Link to post
Share on other sites

I resolved the primary issue with the wizard/designer.

I first verified none of your objects were in the GAC (gacutil /l

>C:\gac.txt) and visually verified in explorer.

Uninstalled, manually deleted any remaining from the default install folder.

Reinstalled .2330 and then without running/testing/using anything - updated

the DLLs and the issue initially reported is resolved.

As to how/why the mismatch would occur if I first used the .2330 version,

accessed the wizard and then upgraded? No idea. The issue with the object

reference after deleting the wizard folder files - I deleted everything in

the wizard folder..apparently, the XML is needed to dynamically create the

dll.

One issue remains and that is with Cross-tabs.

Can you tell me what property needs to be set to create a cross-tab report

using the wizard/designer?

I can do it manually via code without issue, so I know the dataset is

correct, but I was doing it in .2330 with the wizard - when selecting

´Adjust Data to Chart´ it would recognize that fact and offer to create a

cross-tab report. I do not get that with latest version, just the warning

that more than one non-numeric field has been found.

Share this post


Link to post
Share on other sites
Software FX    0

> the XML is needed to dynamically create the dll.

Yes the XML is needed to run the wizard. No XML, no wizard.

I wrote:

"1) Go to the Chart FX installation folder and delete all DLLs from the

Wizard Folder"

> I do not get that with latest version, just the warning that more than one

> non-numeric field has been found

Can you please send me a screenshot of that ? I´m not sure which warning

message you are talking about. The crosstab option will be given to you if

you select three fields, at least two of the fields must be either string or

integers.

--

Francisco Padron

www.chartfx.com

Share this post


Link to post
Share on other sites

Screen shot of the error/dialog is attached.

"Software FX" <noreply@softwarefx.com> wrote in message

news:T7qF7fVUHHA.3588@webserver3.softwarefx.com...

>> the XML is needed to dynamically create the dll.

>

> Yes the XML is needed to run the wizard. No XML, no wizard.

>

> I wrote:

>

> "1) Go to the Chart FX installation folder and delete all DLLs from the

> Wizard Folder"

>

>> I do not get that with latest version, just the warning that more than

>> one

>> non-numeric field has been found

>

> Can you please send me a screenshot of that ? I´m not sure which warning

> message you are talking about. The crosstab option will be given to you if

> you select three fields, at least two of the fields must be either string

> or

> integers.

>

> --

> Francisco Padron

> www.chartfx.com

>

Share this post


Link to post
Share on other sites
Software FX    0

It seems that the CrossTab wizard is deciding that your data is not eligible 

for CrossTab because of lack repetition patterns.

Please modify the ChartFX.Wizard.Config.xml as follows:

Change:

<ChartFX.Wizard.CrossTabPage RealDataRequired="True" UniqueValueAll="50"

UniqueValueRow="30" NumRowsToRead="100"/>

to

<ChartFX.Wizard.CrossTabPage RealDataRequired="True" UniqueValueAll="100"

UniqueValueRow="100" NumRowsToRead="100"/>

--

Francisco Padron

www.chartfx.com

post-2107-13922364377389_thumb.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×