Jump to content
Software FX Community
Sign in to follow this  
Ace27

PSS / Chart Not Rendering.

Recommended Posts

Hello,

I am having an issue with chartfx 7 that I have been working hard to fix. The page contains 4 charts and while they work locally, they do not work in two different environments I have attempted to deploy to. The Issue is that when the page loads the Charts are empty with a red x, the chart tag in the src looks like this...

 

<img width="700" height="400" border="0" src="/ChartFX70/PSS/ChartFX.aspx?id=0-062414380&type=png&mime=image%2fpng" id="ctl06$ctl00$___">

 

Although no pictures show on the page, corresponding files (with no file extension) are still created for each chart in the "Chart FX 7PSSTemp" location instead of the normal "Chart FX 7ChartFX70Temp" location. I can view these files as images If i edit these files to have a .PNG extensions.

 

I have found that disabling the PSS service causes the charts to work in both environments, but its not a recommended practice from what I have read here.

 

Here is some information in regards to setup that I have tried / know

 

  • ChartFX70 is setup in IIS6 as a virtual directory
  • The PSS service has FULL Trust
  • We are using Forms Authentication and I have unsuccessfully tried to configure everything as per the website for this scenario.
  • I have tried to alter the applications web.config to use a separate HTTPHandler for ChartFx.aspx and done the following things
    • include the handler dll in the application bin
    • include the "Chartfx.webforms.config" configuration file (I am not completely sure I set the HandlerURL right in here)
  • I have tried setting the eventloglevel to Trace to see if I could see any additional information aside from the text i have qouted below from the event viewer.
  • I have checked folder permissions on the chartfx folders to make sure the proper rights are granted.

 

The Eventviewer gives an error upon loading charts that contains this info:

Application information:
  Application domain: /RANDOMFOLDER/Root/ChartFX70-1-130481110654931136
  Trust level: Full
  Application Virtual Path: /ChartFX70
  Application Path: C:Program FilesChart FX 7ChartFX70
  Machine name: THISSERVERNAME
 
Process information:
  Process ID: 13564
  Process name: w3wp.exe
  Account name: NT AUTHORITYNETWORK SERVICE
 
Exception information:
  Exception type: ConfigurationErrorsException
  Exception message: Could not load file or assembly 'ChartFX.Pss.HttpHandler' or one of its dependencies. The system cannot find the file specified. (C:Program FilesChart FX 7ChartFX70pssweb.config line 4)
 
Request information:
  Request URL: "hXXp://THISSERVERNAME/chartfx70/pss/ChartFX.aspx?id=0-062412540&type=png&mime=imageA configuration error has occurred.fpng"
  Request path: /chartfx70/pss/ChartFX.aspx
  User host address: 10.XXX.XX.XXX
  User:  
  Is authenticated: False
  Authentication Type:  
  Thread account name: NT AUTHORITYNETWORK SERVICE

 

 

 

Outside of disabling the PSS service, I am fresh out of luck.

 

-Earl

Edited by Ace27

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...