Jump to content
Software FX Community

Recommended Posts

 So I rebooted my server I run the power gadgets on and now any gadgets I try and display it gives me an error.

 Example error:

out-gauge : Cannot process argument because the value of argument "runspaceConfiguration" in null.  Change the value of argument "runspaceConfiguration" to a non-null value.

Share this post


Link to post
Share on other sites
JonathanH    0

 Did you ever get this figured out?  I'm running into the same problem on my dev box now.. I can specifically say that my problem started when I upgraded powershell to powershell 3.0.

Share this post


Link to post
Share on other sites
JonathanH    0

 Just a not to everyone... This is not limited to an "older version" of Powergadgets I had the same issue with the lastest version running.  It appears to be an issue with PowerShell 3.0 and powergadgets in general.  Furthermore, it doesn't occur on *all* of my scripts that use out-gauge.  I was not able to pinpoint a specific difference between the places where it worked and where it didn't, however uninstalling powershell 3.0 fixes the issue.

 This proved to be a real issue for me as I needed powershell 3.0 for another script that I'm running on the box.  Today however I was able to successfully work around this issue with Powershell 3.0 installed.

I re-installed Powershell 3.0 on my machine and confirmed that the same scripts with out-gauge that were previously crashing were still doing so.

I then modified my scheduled tasks that were actually calling the powershell scripts in question to start powershell with the -version 2.0 flag.  When starting powershell with this commandline option before launching my scripts that were crashing in powershell 3.0 everything works fine.

 So if you need powershell 3.0 on the box and also need out-gauge to work, be aware that as long as you aren't needing powershell 3.0 specific features in the scripts that call out-gauge, you can use this workaround to allow things to work.

Share this post


Link to post
Share on other sites
JuanC    0

Can you please send us one of the powershell scripts that worked when you uninstalled powershell 3.0 and stopped working after reinstalling powershell 3.0?

You can send it to support at softwarefx dot com, if it has proprietary information in you can send us an edited version with the out-gauge parameters only as I do not think it depends on the data. It is probably a bug related to one of the parameters or powergadgets template you are using.

JuanC 

Share this post


Link to post
Share on other sites
JonathanH    0

 Well I sent an email this morning, but I'm not sure if you'll get it or not. I actually got an auto-response back basically telling me that the email address is no longer the proper place to send Support requests to.

Share this post


Link to post
Share on other sites
JonathanH    0

 I should also state that when testing a couple of scripts before emailing this, I seem to have found a common denominator.  At least for several of the scripts that were crashing they are ones that had "drill_through" scripts specified. As several of them after removing this parameter they run fine.  Though I do have other scripts that are also using that and work just fine, so still not 100% certain what the combination is.

Share this post


Link to post
Share on other sites
JuanC    0

I apologize for the issue with the email address, please resend your email to products at softwarefx dot com, if possible include a link to this thread so that it can get routed appropriately.

JuanC 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×