Jump to content
Software FX Community
Gharlam

Problem setting data source in Creator

Recommended Posts

I have created a script that outputs a series of dates and totals.

I'm trying to create a new PowerGadget and set the data source to be the .ps1 script file.  When I click finsh, it evaluates, the script and shows the results, but won't save.  Each time I click finish, it re-runs the script.  I have tried pasting the script into the window, but the same thing happens.

I was what I thought was a similar post, with no resolution.

If it matters, I'm running Windows 7 x64.  I also tried this on an XP workstation with the same result.

Help!!

Thanks,

Gary

Share this post


Link to post
Share on other sites

Is there any more information you can provide? 

Maybe this is an issue with PG.  You might have the option of continuing possibly, creating your template file, then editing the template file to add-in the .ps1.  The template file is just simple XML for the most part.

Share this post


Link to post
Share on other sites

Gary,

I was having the exact problem earlier today. I'm not sure exactly what the cause was but its not doing it anymore. I don't remember if I open / closed a pre-existing gadget or open and closed the application multiple times. I know for a fact I'm attempting to use the same ps script. I know this probably doesn't help, but just open / close, restart or w/e it sounds like the creator might be goofing up for some reason.

- Travis

Share this post


Link to post
Share on other sites

I am not sure if I am understanding correctly, but if you are using creator and pointing your gadget to a ps1, this ps1 should only return data, it should not do out-chart/out-gauge

JuanC

Share this post


Link to post
Share on other sites

I have the same issue.

I have a valid PS1 script that runs fine in Powershell.

Load it into Power Gadgets, and it "tests" fine. 

Finish button only retests. 

It does not accept the script. 

Any ideas? 

 

Vista 32bit,  Powershell 2, Powergadget 1.0.3713.29416

Share this post


Link to post
Share on other sites

I was able to make it work using the technique presented in the youtube video

.

They use the ps1 editor to link the ps1 to a generic graph time.Then copy/paste it into PowerGadget Creator, and edit away.

Not sure why just typing it in doesn't work?!?

Share this post


Link to post
Share on other sites

The only difference I can think of between typing the name of the script in the creator and the copy/paste approach would be that when you just use PG Creator the current directory might not be the folder where the script is located.

Have you tried using a fully qualified script path or moving your script to a folder whose path is in the Path environment variable?

JuanC

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...