Jump to content
Software FX Community

FSzymanski

Members
  • Content Count

    11
  • Joined

  • Last visited

Community Reputation

0 Neutral

About FSzymanski

  • Rank
    Member
  1. I am coding a graph that allows users to select data to graph at runtime. I am currently using auto scaling to set up the axis, but I'm running into some concerns. First: Is there any way to have minor steps set up in auto scaling? When the max values is in the hundreds, it looks fine with appropriate steps, but when the max values is small (like 5), the 0-5 with step of 1 doesn't look good. Second: Is there any way to add a buffer to the auto scale max? This graph has point labels set up, but the point with the maximum value has the point label clipping at the top. Attached is a picture from the application that shows both problems.
  2. My experience is that the users can remove the license information from the license.licx file and it will let them compile, but at runtime, trying to access the part of the application that uses the DLL will give you a licensing error. Even if you move the ChartFX code to another library, the .exe project needs the ChartFX licensing information due to how they handle licensing.
  3. Is there any way on a line graph in ChartFX WinForms to have a marker color set without changing the color of the line to the next point? I found one example of this using an old version of ChartFX and the steps mentioned don't translate to the new version. ~Frank
  4. Is there any information about this tooltip? I haven't found any documentation on how to modify or remove this specific tooltip. Additionally, I've found that unlike the axis labels or the point labels, this tooltip is unaffected by an axis' scale unit. For example. my data is stored with the x axis containing elapsed months, but I set the scale unit to 12 to show the data in elapsed years. The X Axis labels correctly show the values by year instead of month. If I hover over a point, the data point tooltip also correctly displays the value by years. However, if I hover over the X Axis, it displays the value by years when setting up the highlighting.
  5. Is there support in Chart FX 7 for broken Axes? An example of what I'm talking of can be seen here: http://peltiertech.com/WordPress/broken-y-axis-in-excel-chart/. I would like to apply this to a line graph. My application lets users select among a set of data to graph, and some of the series have points that are in a largely different range than the others. If they select one series with values in the hundreds of thousands and one that varies between 10 and 20, then the chart will plot from 0 to hundred of thousands and the lower series loses its variance. The user won't be able to see any change in the lower series that they may consider significant. ~Frank
  6. Seeing as this appears to be a problem with my application, is there a way to turn off this label? I've been doing some investigation and cannot find any property that affects this tooltip.
  7. Unfortunately, I cannot use a scatter graph. The chart may have multiple series which may have multiple points. I've noticed that a 3d scatter graph quickly becomes unreadable with multiple series. Is there any way to enable the markershape for 3d ribbon graphs? Our old code which used a ribbon graph had the markershapes displayed.
  8. I have stumbled across two errors in the .NET control. I am using version 7.0.4259.29043 If you only have values of 0 and the Y Axis is set to "Auto" for min and max, the Y Axis will not display any labels at all. Similarly, if you only have a single X Axis value and the min and max are set to Auto, the X Axis will not have any labels. When I set a DataTable as the DataSource and remove the Axis context menu, right clicking an axis item gives me an exception. I used the following code to reproduce the issue: chart1.Data.Clear(); DataTable table = new DataTable(); table.Columns.Add("enc_timestamp", typeof(DateTime)); table.Columns.Add("value", typeof(double)); DataRow row = table.NewRow(); row["enc_timestamp"] = DateTime.Now.AddDays(-60); row["value"] = 5.0; table.Rows.Add(row); row = table.NewRow(); row["enc_timestamp"] = DateTime.Now.AddDays(-30); row["value"] = 25.0; table.Rows.Add(row); row = table.NewRow(); row["enc_timestamp"] = DateTime.Now; row["value"] = 75.0; table.Rows.Add(row); chart1.DataSourceSettings.DataSource = table; chart1.Commands[(int)CommandId.ContextMenuAxis].SubCommands.Clear();
  9. I am currently working on implementing a .NET chart hosted in an MFC form view and I am having an issue with the label that pops up when hovering over an axis. The text and the box that surrounds it are offset, as shown in the attached picture. I was unable to reproduce the issue in a sample application, so I was wondering if anyone could give me a hint as to where to investigate what could cause this problem. At the least, I would like to know how to disable this highlighting effect without disabling highlighting elsewhere on the graph. ~Frank
  10. When platting a 3d line graph, if a series has a single point, nothing will display on the graph. Is there any way around this besides adding a second point to the series? ~Frank
  11. Hello, I'm trying to build a chart using data from my database with dates on the x axis. This data may not match up to the current date, so I was attempting to change the format of the x axis labels from the month with an indication of a change in month (e.g. "January `11") to have the format MM-yyyy. Below is a snippet of setup code that I used: chart1.AxisX.LabelsFormat.Format = AxisFormat.LongDate; chart1.AxisX.LabelsFormat.CustomFormat = "MM-yyyy"; chart1.AxisX.DataFormat.Format = AxisFormat.LongDate; chart1.AxisX.DataFormat.CustomFormat = "MM-dd-yyyy"; chart1.DataSource = ds.Tables[0]; chart1.AxisX.AutoScale = false; chart1.View3D.Enabled = true; chart1.View3D.Cluster = true; chart1.AllSeries.Border.BetweenSegments = true; chart1.AllSeries.Border.Width = 3; When I run the simple app with these settings, I first get a chart that has labels for every other month with the correct format. As I increase the size of the chart, there comes a point where the label switch to the default long date text containing just the month name. If I continue to increase the size of the display, I reach another point where I have multiple labels for the same month. If I add a line setting the X Axis step to 30, then the formatting that I setup is ignored completely and the LongDate formatting is always used. Any help in resolving this would be appreciated. ~Frank
×
×
  • Create New...