Jump to content
Software FX Community

davidib

Members
  • Content count

    10
  • Joined

  • Last visited

Community Reputation

0 Neutral

About davidib

  • Rank
    Member
  1. ListProvider working sporadically

    Hi Frank, can anyone help me with this issue? I've sent the issue to support, not sure what I can expect relative to if someone wil look at the issue and when. Any info/feedback would be appreciated David
  2. I'm having a problem with the ListProvider. I've loaded it with an arraylist which contains 7 series. I add it to the chart properly. However, I have to add the chart to the vs studio watch window and navigate to the Series property of the chart for my app to work, else the app crashes when I try to reference any series I passed to the chart via the ListProvider. Why is this happening?
  3. ListProvider working sporadically

    Frank, please let me know if you can take a look at this or should I just send it to support per you last reply Thanks David
  4. ListProvider working sporadically

    Frank, attached is the project that is incurring the problem. Again the list provider has 7 data series in it, but after I attach the listProvider to the chart the code exceptions out at line 100 in the Form1.designer.cs code with an index out of range. (FWIW the same problem has happened in other projects as well). I've commented out any of my proprietary code and the problem still occurs. Thanks in advance for any help/insight you guys can provide David
  5. ListProvider working sporadically

    Frank, thanks very much. I do have proprietary code in the project so I need to remove that code. FWIW the problem occurs before any of the proprietary code is touched, so removing this code shouldn't have an impact (I'll verify of course). So give me .5 hr and I'll send the project (VS 2005 project). In the meantime, here is a screen print of the problem in the debugger. As you can see in the screen print, 1.the ListProvider object has 7 series attached to it. (Each data series has only 1 element in it purposely). 2.And you can plainly see that the statement to attach the listProvider to the chart (chart1.DataSetting.DataSource = lstProvider. 3.I have a breakpoint right after the above statement executed. 4.Take a look in the lower left hand corner. I have the chart1.Series property displayed in the watch window. It shows a count of 0!
  6. ListProvider working sporadically

    Hi Frank, yes I do. Can I send it to you? Thanks David
  7. Hello, I'm using the listprovider to pass 7 data series to my chart. The code/app works fine, i.e. I see the data I expect to see in the charts/panes I expect them to be in. However sometimes I'll run the app, and for some reason the code exceptions out with an index out of range error. I've tracked this error down and discovered that sometimes the chart will show the series count as 0 (I.e. the Series property), even though the listprovider shows it has the 7 data series in it. Additionally, sometime the chart Series property will show a Count of 0, but when I drill down into the Series, it shows a count of 7. What is going on here? FWIW I've run the app only in the debugger. Also I am programatically building the data series and the listProvider, i.e. there is no datasource associated with the chart at design time Thanks for any help you can provide David
  8. I'm trying to add an extra series to a financial chart and am not sure how to accomplish this. Is it just a matter of setting the number of series of the chart to 7 (series 0 thru 5 are used by the financial open high low close vol date extesion) and then manipulating series 6 of the chart? any help greatly appreciated. Thanks in advance David
  9. Hi Juan, thanks for the reply. I'll try it. Also I did incorrectly code '100' vs '1000'. After fixing the code, the market color worked properly. BTW I can't find any reference to the PointLabelMask property. I have the printed manual, the online help and a local help file. If I do a search for PointLabelMask in the online help, I don't get any hits. Reason I mention this is that while I think ChartFX is a great product, I get the sense that the only way to figure out how use ChartFX is to continually graze for a solution by trial and error, not a very efficient way to develop. Do you have any suggestions regarding the best way to get familiar with ChartFX? Thanks again for your reply. David
  10. Hi, I must be doing something stupid but I've spent the last 2-3 hours trying to get this to work to no avail and now I'm desperate All I want to do is add a custom text label to a certain point in my chart that has a single series. Per the code and comment below, some of the point specific methods/properties seem to to work, others do not. Is there any reason for this? Why would the Marker shape/size work so obviously/easily, but the color of the Marker not work at all? Thanks for any help you can provide David //my code snippet, try to label a point!!chart1.Points[0, 100].Color = System.Drawing.Color.Blue; //DOES NOT WORK no matter what color I choose chart1.Points[0, 1000].PointLabels.TextColor = System.Drawing. Color.Blue; //DOES WORK chart1.Points[0, 1000].PointLabels.Font = new Font("Arial", 10); //DOES WORK chart1.Points[0, 1000].PointLabels.Visible = true; //DOES WORK, shows the value of the data at that pointchart1.Points[0, 1000].MarkerShape = ChartFX.WinForms.MarkerShape.InvertedTriangle; //DOES WORK chart1.Points[0, 1000].MarkerSize = 10; //DOES WORK chart1.Points[0, 1000].Text = "XXX"; //DOES NOT WORK, (no matter where I place this stmt in the code) argh!!!!! > chart1.Refresh();
×